Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Error in exercise 2: exporting tables from MySQL to HDFS

avatar
Explorer

When I run the following command:

sqoop import-all-tables \
    -m 1 \
    --connect jdbc:mysql://quickstart:3306/retail_db \
    --username=retail_dba \
    --password=cloudera \
    --compression-codec=snappy \
    --as-avrodatafile \
    --warehouse-dir=/user/hive/warehouse

I get the following error:

/usr/lib/sqoop/bin/sqoop: line 101: /usr/jars/bin/hadoop: No such file or directory
/usr/lib/sqoop/bin/sqoop: line 101: exec: /usr/jars/bin/hadoop: cannot execute: No such file or directory

 

I tried to remove that file using:

hadoop fs -rm -r -skipTrash /usr/jars/bin/hadoop

 

I still get the same error!!!!!

any suggestions????

 

2 ACCEPTED SOLUTIONS

avatar
Community Manager

Perhaps this other thread will be of assistance.  

 

tutorial exercise 2: no tables

Keep the questions coming

View solution in original post

avatar
Explorer

Thanks for following up. Problem is solved; I ran hive server and made the namenode leave the safe mode. Then the command included in the thread you posted worked finally.

View solution in original post

5 REPLIES 5

avatar
Community Manager

Perhaps this other thread will be of assistance.  

 

tutorial exercise 2: no tables

Keep the questions coming

avatar
Explorer

Thanks for the suggestion! I tried the suggested commands but I still have the same problem. 

avatar
Community Manager

Sorry to hear that. Hopefully someone more knowledgable than I will jump in with something better. 

Keep the questions coming

avatar
Explorer

Thanks for following up. Problem is solved; I ran hive server and made the namenode leave the safe mode. Then the command included in the thread you posted worked finally.

avatar
Community Manager
Great! Feel free to mark your last comment as the solution. Perhaps it will help others as well.
Keep the questions coming