Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 06-01-2017 07:52 PM
Hi Team,
While trying to install standalone Ambari server on one of the existing edge node. Below is the error I got every time when I ran ambari-server setup command.
SELinux status is 'disabled'
Customize user account for ambari-server daemon [y/n] (n)?
ERROR: Unexpected error 'getpwuid(): uid not found: 55025'
ERROR: Exiting with exit code 1.
REASON: Failed to create user. Exiting.
Also, I don't see UID "55025" in the /etc/passwd and wondering from where it's picking this UID.
Thanks
Created 06-02-2017 10:59 AM
Can you check the permissions on your ambari files, especially the repo file?
Created 06-02-2017 10:59 AM
Can you check the permissions on your ambari files, especially the repo file?
Created 06-02-2017 11:09 AM
@awhitter Thanks a lot. Ambari repo file permission was wrong.
Created 06-02-2017 11:37 AM
Can you please check which user has the permission to read write this file?
# ls -la /etc/yum.repos.d/ambari.repo -rw-r--r--. 1 root root 304 May 31 17:08 /etc/yum.repos.d/ambari.repo
.
You can verify the same using this Python script"
import os
import pwd
print 'Who Owns it: ' + pwd.getpwuid(os.stat("/etc/yum.repos.d/ambari.repo").st_uid).pw_name.
Now If do the following:
# useradd 55025 # chown 55025 /etc/yum.repos.d/ambari.repo
.
Then you will see 55025 in the output.