Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 04-03-2016 12:14 PM
when i run command '
wget -nv http://private-repo-1.hortonworks.com/HDP/centos6/2.x/updates/2.3.4.1-10/hdp.repo -O /etc/yum.repos.d/HDP-TP.repo'
command in Zeppelin, getting error as
<console>:2: error: ';' expected but '(' found. print("")
Ps help.
Sandbox HDP version is 2.3.2
Created 04-03-2016 01:36 PM
Hi @Rajendra Vechalapu, you need to login as root to your Sandbox or a machine where you want to install Spark and run the wget command there. It's also assuming that your OS is CentOS or RHEL-6. I just tried and it works (the URL is still valid). After that run "yum install" and follow all other steps on that page before trying Spark from the command line (test the command line first) or from Zeppelin.
Created 04-03-2016 12:15 PM
It is from ,
http://hortonworks.com/hadoop-tutorial/a-lap-around-apache-spark/ site
Created 04-03-2016 01:36 PM
Hi @Rajendra Vechalapu, you need to login as root to your Sandbox or a machine where you want to install Spark and run the wget command there. It's also assuming that your OS is CentOS or RHEL-6. I just tried and it works (the URL is still valid). After that run "yum install" and follow all other steps on that page before trying Spark from the command line (test the command line first) or from Zeppelin.
Created 04-03-2016 01:46 PM
Thank you for your reply, but from Zeppelin it is not working. Pls note that I am using hortonworks sanbox VM on Windows 7 OS. even tried directly in command prompt but still got errors.
Created 04-03-2016 01:55 PM
Login to your sandbox using "ssh -p2222 root@localhost" and then run wget and yum commands from the command line, and all other commands from the tutorial.
Created 04-03-2016 02:29 PM
@Rajendra Vechalapu, I just realized that all details are not explained anywhere. So on Windows you need an ssh client, you can download Putty for example. Then in Putty type "localhost" as hostname and port 2222 and then try to login. You can also try a web ssh client at http://localhost:4200.
Created 04-04-2016 03:02 AM
It worked, Thank you
Created 04-04-2016 03:34 AM
Hi @Rajendra Vechalapu glad to hear that it worked! If so, can you consider to upvote and/or accept my answer. By the way HCC works similar to "Stack Overflow": It serves as a platform for users to ask and answer questions related to HDP and Hadoop in general, and, through membership and active participation, to vote questions and answers up or down, accept answeres and edit questions and answers. In addition to Q&A there are also articles, ideas and repos sections. Tnx!