Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 05-10-2017 08:11 AM - edited 08-17-2019 06:29 PM
Creating target directory...
========================== Command start time 2017-05-09 15:50:41 Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password). SSH command execution finished host=ambari.sierra.com, exitcode=255 Command end time 2017-05-09 15:50:41 ERROR: Bootstrap of host ambari.sierra.com fails because previous action finished with non-zero exit code (255) ERROR MESSAGE: Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password). STDOUT: Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).
Created 05-10-2017 08:24 AM
Few things to check on the problematic host:
1. Are you able to do password less ssh to the localhost? Or the host where the agent installation is failing?
ssh [email protected] ssh root@localhost
2. Check the permission of the ssk keys on the mentioned host.Should be 600 for authorized keys:
# ls -l ~/.ssh/ total 16 -rw-------. 1 root root 412 Aug 18 2016 authorized_keys -rw-------. 1 root root 1675 Feb 13 04:01 id_rsa -rw-r--r--. 1 root root 404 Feb 13 04:01 id_rsa.pub -rw-r--r--. 1 root root 826 Feb 13 04:01 known_hosts [root@erie1 ambari-server]# ls -l ~/.ssh/authorized_keys -rw-------. 1 root root 412 Aug 18 2016 /root/.ssh/authorized_keys
3. Verify that there is no ambari agent RPM is not already installed on the mentioned host
rpm -qa | grep ambari
If nothing works then at the end try creating the SSK keys again on the "ambari.sierra.com" again
OR
try installing ambari agent on that problematic host manually. http://docs.hortonworks.com/HDPDocuments/Ambari-2.5.0.3/bk_ambari-administration/content/ch_amb_ref_...
.
Created 05-10-2017 08:24 AM
Few things to check on the problematic host:
1. Are you able to do password less ssh to the localhost? Or the host where the agent installation is failing?
ssh [email protected] ssh root@localhost
2. Check the permission of the ssk keys on the mentioned host.Should be 600 for authorized keys:
# ls -l ~/.ssh/ total 16 -rw-------. 1 root root 412 Aug 18 2016 authorized_keys -rw-------. 1 root root 1675 Feb 13 04:01 id_rsa -rw-r--r--. 1 root root 404 Feb 13 04:01 id_rsa.pub -rw-r--r--. 1 root root 826 Feb 13 04:01 known_hosts [root@erie1 ambari-server]# ls -l ~/.ssh/authorized_keys -rw-------. 1 root root 412 Aug 18 2016 /root/.ssh/authorized_keys
3. Verify that there is no ambari agent RPM is not already installed on the mentioned host
rpm -qa | grep ambari
If nothing works then at the end try creating the SSK keys again on the "ambari.sierra.com" again
OR
try installing ambari agent on that problematic host manually. http://docs.hortonworks.com/HDPDocuments/Ambari-2.5.0.3/bk_ambari-administration/content/ch_amb_ref_...
.
Created 05-10-2017 09:16 AM
I have nothing to add. I just wanted to know why ambari-agent should not be installed on that host? Point 3 in your post.
Created 05-10-2017 09:36 AM
Created 05-10-2017 09:41 AM
Och ok, thank you for explanation.
Created 05-11-2017 06:46 AM
@Jay SenSharma, Thank you for the explanation.It worked
Created 05-11-2017 07:22 AM