Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-01-2016 06:13 PM
We recently upgraded out Hadoop cluster from 6.2.6 to 6.3.4 and i am getting the below error while trying to read data from kafka-topic. Any help to resolve this issue is highly appreciated.
$KAFKA_HOME/bin/kafka-console-consumer.sh --zookeeper xxxxxxx:2181 --topic xxxxxxxxxxxx
SLF4J: Class path contains multiple SLF4J bindings. SLF4J: Found binding in [jar:file:/usr/hdp/2.3.4.7-4/kafka/libs/slf4j-log4j12-1.7.6.jar!/org/slf4j/impl/StaticLoggerBinder.class] SLF4J: Found binding in [jar:file:/usr/hdp/2.3.4.7-4/phoenix/phoenix-4.4.0.2.3.4.7-4-client.jar!/org/slf4j/impl/StaticLoggerBinder.class] SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation. SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory] [2016-07-01 12:55:01,829] WARN SASL configuration failed: javax.security.auth.login.LoginException: Zookeeper client cannot authenticate using the 'Client' section of the supplied JAAS configuration: '/usr/hdp/current/kafka-broker/config/kafka_client_jaas.conf' because of a RuntimeException: java.lang.SecurityException: /usr/hdp/current/kafka-broker/config/kafka_client_jaas.conf (No such file or directory) Will continue connection to Zookeeper server without SASL authentication, if Zookeeper server allows it. (org.apache.zookeeper.ClientCnxn) [2016-07-01 12:55:02,062] ERROR Unknown error when running consumer: (kafka.tools.ConsoleConsumer$) org.apache.kafka.common.KafkaException: File /usr/hdp/current/kafka-broker/config/kafka_client_jaas.confcannot be read. at org.apache.kafka.common.security.JaasUtils.isZkSecurityEnabled(JaasUtils.java:95) at kafka.consumer.ZookeeperConsumerConnector.connectZk(ZookeeperConsumerConnector.scala:200) at kafka.consumer.ZookeeperConsumerConnector.<init>(ZookeeperConsumerConnector.scala:145) at kafka.consumer.ZookeeperConsumerConnector.<init>(ZookeeperConsumerConnector.scala:162) at kafka.consumer.Consumer$.create(ConsumerConnector.scala:109) at kafka.consumer.OldConsumer.<init>(BaseConsumer.scala:82) at kafka.tools.ConsoleConsumer$.run(ConsoleConsumer.scala:63) at kafka.tools.ConsoleConsumer$.main(ConsoleConsumer.scala:47) at kafka.tools.ConsoleConsumer.main(ConsoleConsumer.scala)
Thanks.
Created 07-02-2016 05:29 PM
This error seems to appear when we add cluster to secure cluster. Could you please verify your authentication capability to Kafka brokers added for encryption with this upgrade.
Created 07-02-2016 05:29 PM
This error seems to appear when we add cluster to secure cluster. Could you please verify your authentication capability to Kafka brokers added for encryption with this upgrade.