Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 05-21-2017 12:04 PM - edited 09-16-2022 04:38 AM
I am installing the cloudera 5.11 in centos and I had an error with zookeeper. The error is the following:
2017-05-21 15:44:59,355 ERROR org.apache.zookeeper.server.ZooKeeperServerMain: Unable to access datadir, exiting abnormally
org.apache.zookeeper.server.persistence.FileTxnSnapLog$DatadirException: Missing data directory /var/lib/zookeeper/version-2, automatic data directory creation is disabled (zookeeper.datadir.autocreate is false). Please create this directory manually.
at org.apache.zookeeper.server.persistence.FileTxnSnapLog.<init>(FileTxnSnapLog.java:102)
at org.apache.zookeeper.server.ZooKeeperServerMain.runFromConfig(ZooKeeperServerMain.java:109)
at org.apache.zookeeper.server.ZooKeeperServerMain.initializeAndRun(ZooKeeperServerMain.java:91)
at org.apache.zookeeper.server.ZooKeeperServerMain.main(ZooKeeperServerMain.java:53)
at org.apache.zookeeper.server.quorum.QuorumPeerMain.initializeAndRun(QuorumPeerMain.java:121)
at org.apache.zookeeper.server.quorum.QuorumPeerMain.main(QuorumPeerMain.java:79)
The complete log is in the next pastebin link:
anyone had the same problem?
Thanks in advance!
Created 05-22-2017 01:48 AM
What is the permission of the created directory?
Is SELinux disabled in your system?
Created 05-22-2017 12:25 AM
Why don't you create /var/lib/zookeeper/version-2 mannualy or zookeeper.datadir.autocreate to true and try.
Created 05-22-2017 12:34 AM
Created 05-22-2017 01:48 AM
What is the permission of the created directory?
Is SELinux disabled in your system?
Created 05-25-2017 07:25 AM
Thanks, I forgot disable SELinux.