Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 01-12-2017 06:18 PM - edited 09-16-2022 03:54 AM
Hello,
Today, when I run "compute stats" command in Impala, I got this kind of error.
Can you tell me what I need to check to root-cause the issue?
I've restart Impala cluster in case, but still doesn't work.
Thank you
Gatsby
Query (id=e14f8e09bc61152e:edb3c88b00000000):
Summary:
Session ID: ec4783541c02a53b:94e307a26bcc719e
Session Type: BEESWAX
Start Time: 2017-01-12 17:17:13.717774000
End Time: 2017-01-12 17:17:14.027669000
Query Type: DDL
Query State: EXCEPTION
Query Status: ExecPlanRequest rpc query_id=fb4b42b5b270a117:f7b20fe800000000 instance_id=fb4b42b5b270a117:f7b20fe800000001 failed: RPC Error: No more data to read.
Impala Version: impalad version 2.8.0-cdh5-INTERNAL RELEASE (build )
User: root
Connected User: root
Delegated User:
Network Address: ::ffff:10.168.16.16:44184
Default Db: default
Sql Statement: compute STATS onlinemarketing_201701
Coordinator: hadoop2-wn2.dwarehouse.internal:22000
Query Options (non default):
DDL Type: COMPUTE_STATS
: 0.000ns
Query Timeline: 310.440ms
- Start execution: 68.354us (68.354us)
- Planning finished: 2.602ms (2.533ms)
- Request finished: 265.917ms (263.315ms)
- Unregister query: 309.901ms (43.983ms)
ImpalaServer:
- ClientFetchWaitTimer: 0.000ns
- RowMaterializationTimer: 0.000ns
Created 01-26-2017 10:38 AM
I found out what caused this issue in this case.
Nodes have different Impala version, such as 2.8, 2.4 etc.
The interesting thing is that `compute stats` operation didn't work if run in Impala 2.8,
but the operation works in Impala 2.4.
Anyway, I hope this can help you solve your problem.
Thank you
Gatsby
Created 01-25-2017 05:11 PM
Is this related to kerberos authentication??
Created 01-26-2017 10:38 AM
I found out what caused this issue in this case.
Nodes have different Impala version, such as 2.8, 2.4 etc.
The interesting thing is that `compute stats` operation didn't work if run in Impala 2.8,
but the operation works in Impala 2.4.
Anyway, I hope this can help you solve your problem.
Thank you
Gatsby