Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 10-03-2015 06:40 PM - edited 09-16-2022 02:42 AM
Hi,
Not getting any response When I execute below query. Its more than 3 hrs now and no response yet. I am running this query on Quick Start VM.
Could you please help me with this issue.
CREATE EXTERNAL TABLE intermediate_access_logs ( ip STRING, date STRING, method STRING, url STRING, http_version STRING, code1 STRING, code2 STRING, dash STRING, user_agent STRING) ROW FORMAT SERDE 'org.apache.hadoop.hive.contrib.serde2.RegexSerDe' WITH SERDEPROPERTIES ( 'input.regex' = '([^ ]*) - - \\[([^\\]]*)\\] "([^\ ]*) ([^\ ]*) ([^\ ]*)" (\\d*) (\\d*) "([^"]*)" "([^"]*)"', 'output.format.string' = "%1$s %2$s %3$s %4$s %5$s %6$s %7$s %8$s %9$s" ) LOCATION '/user/hive/warehouse/original_access_logs';
Created 10-04-2015 09:48 AM
Resolved the issue. Issue is because Zookeeper service is not running.
Created 10-03-2015 08:31 PM
This is what i get when executing the query:
Error: Error while processing statement: FAILED: Execution Error, return code 1 from org.apache.hadoop.hive.ql.exec.DDLTask. MetaException(message:hdfs://quickstart.cloudera:8020/user/hive/warehouse/original_access_logs is not a directory or unable to create one) (state=08S01,code=1)
0: jdbc:hive2://quickstart:10000/default>
Created 10-03-2015 09:22 PM
This worked for me:
--remove existing directory
sudo -u hdfs hadoop fs rm /user/hive/warehouse/original_access_logs
--create the directory again
--see the results. must be drwxr ...
hadoop fs -ls /user/hive/warehouse
--Found 9 items
drwxr-xr-x - cloudera hive 0 2015-10-03 18:51 /user/hive/warehouse/categories
drwxr-xr-x - cloudera hive 0 2015-10-03 18:52 /user/hive/warehouse/customers
drwxr-xr-x - cloudera hive 0 2015-10-03 18:53 /user/hive/warehouse/departments
drwxr-xr-x - cloudera hive 0 2015-10-03 18:53 /user/hive/warehouse/order_items
drwxr-xr-x - cloudera hive 0 2015-10-03 18:54 /user/hive/warehouse/orders
drwxr-xr-x - hdfs hive 0 2015-10-03 21:17 /user/hive/warehouse/original_access_logs
drwxr-xr-x - hdfs hive 0 2015-10-03 19:33 /user/hive/warehouse/originala_access_logs
drwxr-xr-x - cloudera hive 0 2015-10-03 18:55 /user/hive/warehouse/products
drwxrwxrwx - admin hive 0 2015-10-03 20:37 /user/hive/warehouse/tokenized_access_logs
Created 10-04-2015 08:08 AM
No luck with the solution. Verified the permissions 9drwxr )
Any help?
Created 10-03-2015 09:12 PM
It took around 4 Hrs to finish the query with errors.
I got an error saying that Failed to acquire locks
Created 10-04-2015 09:48 AM
Resolved the issue. Issue is because Zookeeper service is not running.
Created 10-04-2015 05:46 PM
Created 10-05-2015 07:37 AM