Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
06-19-2017
06:27 AM
- last edited on
04-21-2026
05:22 AM
by
GrazittiAPI
Hi,
When I click the Nifi start button on Ambari, it would become green for a second, but immediately become red. I got the below error in nifi-app.log. It complains 'Address already in use', but I confirmed no process on the node was using 9090 port. Does anyone happen to experience this and know the resolution?
2017-06-19 06:15:14,304 INFO [main] o.e.jetty.server.handler.ContextHandler Started o.e.j.w.WebAppContext@27bfa57f{/,file:///var/lib/nifi/work/jetty/nifi-web-error-1.2.0.3.0.0.0-453.war/webapp/,AVAILABLE}{/var/lib/nifi/work/nar/framework/nifi-framework-nar-1.2.0.3.0.0.0-453.nar-unpacked/META-INF/bundled-dependencies/nifi-web-error-1.2.0.3.0.0.0-453.war}
2017-06-19 06:15:14,326 INFO [main] o.eclipse.jetty.server.AbstractConnector Started ServerConnector@11636d43{HTTP/1.1,[http/1.1]}{hdf.example.com:9090}
2017-06-19 06:15:14,327 INFO [main] org.eclipse.jetty.server.Server Started @39995ms
2017-06-19 06:15:15,528 INFO [main] org.apache.nifi.web.server.JettyServer Loading Flow...
2017-06-19 06:15:15,541 INFO [Curator-Framework-0] o.a.c.f.imps.CuratorFrameworkImpl backgroundOperationsLoop exiting
2017-06-19 06:15:15,541 INFO [Leader Election Notification Thread-1] o.a.n.c.l.e.CuratorLeaderElectionManager org.apache.nifi.controller.leader.election.CuratorLeaderElectionManager$ElectionListener@e11427 has been interrupted; no longer leader for role 'Cluster Coordinator'
2017-06-19 06:15:15,541 INFO [Leader Election Notification Thread-1] o.a.n.c.l.e.CuratorLeaderElectionManager org.apache.nifi.controller.leader.election.CuratorLeaderElectionManager$ElectionListener@e11427 This node is no longer leader for role 'Cluster Coordinator'
2017-06-19 06:15:15,541 INFO [Leader Election Notification Thread-1] o.apache.nifi.controller.FlowController This node is no longer the elected Active Cluster Coordinator
2017-06-19 06:15:15,556 INFO [main] o.a.n.c.l.e.CuratorLeaderElectionManager CuratorLeaderElectionManager[stopped=true] stopped and closed
2017-06-19 06:15:15,557 INFO [main] o.a.n.c.c.h.AbstractHeartbeatMonitor Heartbeat Monitor stopped
2017-06-19 06:15:15,558 INFO [main] o.apache.nifi.controller.FlowController Initiated immediate shutdown of flow controller...
2017-06-19 06:15:16,395 INFO [main] o.apache.nifi.controller.FlowController Controller has been terminated successfully.
2017-06-19 06:15:16,409 WARN [main] org.apache.nifi.web.server.JettyServer Failed to start web server... shutting down.
java.lang.Exception: Unable to load flow due to: org.apache.nifi.lifecycle.LifeCycleStartException: Failed to start Flow Service due to: java.net.BindException: Address already in use
at org.apache.nifi.web.server.JettyServer.start(JettyServer.java:809)
at org.apache.nifi.NiFi.<init>(NiFi.java:160)
at org.apache.nifi.NiFi.main(NiFi.java:267)
Caused by: org.apache.nifi.lifecycle.LifeCycleStartException: Failed to start Flow Service due to: java.net.BindException: Address already in use
at org.apache.nifi.controller.StandardFlowService.start(StandardFlowService.java:312)
at org.apache.nifi.web.server.JettyServer.start(JettyServer.java:799)
... 2 common frames omitted
Caused by: java.net.BindException: Address already in use
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.AbstractPlainSocketImpl.bind(AbstractPlainSocketImpl.java:387)
at java.net.ServerSocket.bind(ServerSocket.java:375)
at java.net.ServerSocket.<init>(ServerSocket.java:237)
at java.net.ServerSocket.<init>(ServerSocket.java:128)
at org.apache.nifi.io.socket.SocketUtils.createServerSocket(SocketUtils.java:108)
at org.apache.nifi.io.socket.SocketListener.start(SocketListener.java:85)
at org.apache.nifi.cluster.protocol.impl.SocketProtocolListener.start(SocketProtocolListener.java:90)
at org.apache.nifi.cluster.protocol.impl.NodeProtocolSenderListener.start(NodeProtocolSenderListener.java:64)
at org.apache.nifi.controller.StandardFlowService.start(StandardFlowService.java:303)
... 3 common frames omitted
2017-06-19 06:15:16,411 INFO [Thread-1] org.apache.nifi.NiFi Initiating shutdown of Jetty web server...
2017-06-19 06:15:16,423 INFO [Thread-1] o.eclipse.jetty.server.AbstractConnector Stopped ServerConnector@11636d43{HTTP/1.1,[http/1.1]}{hdf.example.com:9090}
2017-06-19 06:15:16,424 INFO [Thread-1] org.eclipse.jetty.server.session Stopped scavenging
Created 06-19-2017 07:44 AM
@yjiang Have you installed NiFi on the same server as Superset? They have a default port clash on 9088 - I suggest you search in the NiFi configs for 9088 and change it to 9089 (9089 is free in a default install).
Created 06-19-2017 07:44 AM
@yjiang Have you installed NiFi on the same server as Superset? They have a default port clash on 9088 - I suggest you search in the NiFi configs for 9088 and change it to 9089 (9089 is free in a default install).
Created 06-19-2017 11:46 AM
Thanks @Dan Chaffelson
Changing Nifi protocol port to 9089 works.
Created on 07-07-2019 04:16 AM - edited 08-17-2019 08:46 PM
Got the same error. Your hint works.
2019-07-07 13:10:17,764 ERROR [main] org.apache.nifi.web.server.JettyServer Unable to load flow due to: org.apache.nifi.lifecycle.LifeCycleStartException: Failed to start Flow Service due to: java.net.SocketException: アドレスは既に使用中です (Listen failed) org.apache.nifi.lifecycle.LifeCycleStartException: Failed to start Flow Service due to: java.net.SocketException: アドレスは既に使用中です (Listen failed) at org.apache.nifi.controller.StandardFlowService.start(StandardFlowService.java:323) at org.apache.nifi.web.server.JettyServer.start(JettyServer.java:1008) at org.apache.nifi.NiFi.<init>(NiFi.java:158) at org.apache.nifi.NiFi.<init>(NiFi.java:72) at org.apache.nifi.NiFi.main(NiFi.java:297) Caused by: java.net.SocketException: アドレスは既に使用中です (Listen failed) at java.net.PlainSocketImpl.socketListen(Native Method) at java.net.AbstractPlainSocketImpl.listen(AbstractPlainSocketImpl.java:399) at java.net.ServerSocket.bind(ServerSocket.java:376) at java.net.ServerSocket.<init>(ServerSocket.java:237) at java.net.ServerSocket.<init>(ServerSocket.java:128) at org.apache.nifi.io.socket.SocketUtils.createServerSocket(SocketUtils.java:108) at org.apache.nifi.io.socket.SocketListener.start(SocketListener.java:85) at org.apache.nifi.cluster.protocol.impl.SocketProtocolListener.start(SocketProtocolListener.java:97) at org.apache.nifi.cluster.protocol.impl.NodeProtocolSenderListener.start(NodeProtocolSenderListener.java:64) at org.apache.nifi.controller.StandardFlowService.start(StandardFlowService.java:314) ... 4 common frames omitted 2019-07-07 13:10:17,766 WARN [main] org.apache.nifi.web.server.JettyServer Failed to start web server... shutting down.