Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 05-30-2016 05:31 PM - edited 08-19-2019 04:33 AM
Hi,
I set up two HDP clusters and tried to use Falcon to mirror data from one cluster to another.
I could created two clusters and configured the mirror setting on Falcon UI without error. I could also see the mirroring MR job completed successfully. However, files do not get mirrored from source to target.
I am attaching my Falcon Mirror setting. Am I missing anything?
Created 06-01-2016 08:24 AM
Thanks @yzheng
The mirror instance is in healthy status.
After upgraded the target cluster to 2.3.4 and changed to job to run on source cluster, it works now.
Created 05-30-2016 06:16 PM
@yjiang What is the HDP version you are using, for which you have seen that Falcon does not mirror data.
Created 05-30-2016 11:21 PM
@peeyush That is the target cluster running HDP 2.3.4.7-4. The source cluster is HDP 2.4.2.0
Created 05-31-2016 05:46 AM
Created 06-01-2016 01:11 AM
@yjiang Could you check the mirror instance status? You can run CLI command
bin/falcon instance -list -type process -name [your-mirror-name]
If it is failed or killed, could you check Oozie site on error details?
Created 06-01-2016 08:24 AM
Thanks @yzheng
The mirror instance is in healthy status.
After upgraded the target cluster to 2.3.4 and changed to job to run on source cluster, it works now.
Created 06-01-2016 03:09 PM
@yjiang Great!
Created 06-01-2016 11:54 PM
There is a bug in hdfs replication workflow FALCON-189 causing this. As a quick fix, edit drSourceDir to include source FS, so that it become: ${drSourceClusterFS}${drSourceDir} as discussed in the Jira. The file to fix is
/usr/hdp/current/falcon-server/data-mirroring/workflows/hdfs-replication-workflow.xml
on your Falcon server. Then upload the file to /apps/data-mirroring/workflows in HDFS. Restart Falcon and retry to run mirroring from the target cluster.
Created 12-05-2016 01:47 AM
Upload the hdfs-replication-workflow.xml into hdfs will resolve this problem.
i.e. create a hdfs directory /apps/data-mirroring/workflows and upload it