Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 10-22-2016 03:00 AM
Hi,
I'm a newbie to HDP and just set up a lab environment with 5 nodes. Installation went well but error happens when I try to upload a file with File View.
Before doing that, I created a local user as well as a home folder in HDFS for that user, using command below:
sudo -u hdfs hdfs dfs -mkdir /user/test
sudo -u hdfs hdfs dfs -chown test:hadoop /user/test
I could then create subfolder under /user/test. However, when uploading a file I got error
Unauthorized connection for super-user: root from IP 192.168.199.211
Anything I may have missed? Thanks in advance!
Created 10-22-2016 03:03 AM
Created 10-22-2016 03:03 AM
Created 10-22-2016 03:03 AM
The values should be * for both the properties.
Created 10-22-2016 03:37 AM
@srai Much appreciate your prompt answer! I fixed it by change "hadoop.proxyuser.hdfs.hosts" ambari server from "hdp1" to "*", where hdp1 is the host name of my ambari server. Any idea why at the first place only ambari server is put in here?
Created 10-22-2016 03:39 AM
Thats the default entry when configuring via Ambari. This is a pain everyone goes through 🙂
Created 10-22-2016 03:51 AM
Got it! Thanks!