Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-01-2016 08:56 PM
We are installing HDP 2.3 using Ambari 2.1.2 on CentOS 6.5 and running into an issue where hdfs client fails to install due to what appears to be a bad symlink.
There is a symlink in this location which appears to be broken, linking to /etc/hadoop/conf, which then links back to /usr/hdp/current/hadoop-client/conf. This results in a cyclical link. We are importing a blueprint to create the cluster. This same blueprint works fine in another environment. I am not sure what to look for in order to resolve this error.
File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 87, in action_create
raise Fail("Applying %s failed, parent directory %s doesn't exist" % (self.resource, dirname))
resource_management.core.exceptions.Fail: Applying File['/usr/hdp/current/hadoop-client/conf/hadoop-policy.xml'] failed, parent directory /usr/hdp/current/hadoop-client/conf doesn't exist
Created 02-02-2016 06:21 PM
I figured it out. We had multiple versions of the rpms in our local yum repo (build 2434 and build 2557) so ambari was confused and pulling older rpms, causing this error.
Created 02-01-2016 09:57 PM
It did happen when I used the environment for the install after cleaning up previous install. If that's the case then you need to make sure that the cleanup did happen completely.
Created 05-08-2017 04:39 PM
Hey @Jason Reslock , i am facing similar issue while trying to reinstall , but how to make sure that cleanup did happen completely?
Created 02-01-2016 10:46 PM
@Jason Reslock
Is hdfs-client installed on that host?
As always, verify correct permissions exist on the directories.
Ex:
lrwxrwxrwx 1 root root 28 Oct 14 18:24 hadoop-client -> /usr/hdp/2.2.0.0-2041/hadoop
Created 02-02-2016 06:21 PM
I figured it out. We had multiple versions of the rpms in our local yum repo (build 2434 and build 2557) so ambari was confused and pulling older rpms, causing this error.