Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 09-19-2017 11:54 AM
Hi All,
Is there a way to only make AD username as the owner of HDFS files/directories instead of userName@domainName.
Current Scenario :
hdfs dfs -ls /testfile -rw-r--r-- 3 [email protected] hdfs 0 2017-06-30 10:06 /testfile
I want this to be like below.
hdfs dfs -ls /testfile -rw-r--r-- 3 dgiri hdfs 0 2017-06-30 10:06 /testfile
Please note that cluster is AD integrated and everything is working fine as expected except the files/directories ownership.
Also, I'm getting below INFO message whenever I run hdfs commands. Is there a way to stop displaying below message ?
17/09/19 12:50:13 INFO util.KerberosName: No auth_to_local rules applied to [email protected]
Any help is much appreciated.
Thanks.
Created 09-19-2017 07:28 PM
You will need to add auth_to_local rule in core-site.xml to map [email protected] to dgiri
RULE:[2:$1](.*@mytestdomain.com)s/@.*//
More defailt of how to write auth_to_local rules can be found here: https://hortonworks.com/blog/fine-tune-your-apache-hadoop-security-settings/
Created 09-19-2017 07:28 PM
You will need to add auth_to_local rule in core-site.xml to map [email protected] to dgiri
RULE:[2:$1](.*@mytestdomain.com)s/@.*//
More defailt of how to write auth_to_local rules can be found here: https://hortonworks.com/blog/fine-tune-your-apache-hadoop-security-settings/
Created 09-25-2017 09:11 AM
Thanks @Xiaoyu Yao for the details and documentation link.