Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-05-2015 03:28 PM
Hi,
I am trying manually to set up hdfs ha with no luck.. I do everything exactly like here: http://www.cloudera.com/content/cloudera/en/documentation/core/latest/topics/cmug_topic_5_12_unique_... but at the end, I'll get this error:
INFO org.apache.hadoop.hdfs.server.namenode.FSNamesystem: Determined nameservice ID: mycluster
INFO org.apache.hadoop.hdfs.server.namenode.FSNamesystem: HA Enabled: false
WARN org.apache.hadoop.hdfs.server.namenode.FSNamesystem: Configured NNs:
142 ERROR org.apache.hadoop.hdfs.server.namenode.FSNamesystem: FSNamesystem initialization failed.
java.io.IOException: Invalid configuration: a shared edits dir must not be specified if HA is not enabled.
Why ha enabled is false and system doesn't see my NNs (nn1,nn2).
Please advice me, what am i doing wrong...
Created 02-07-2015 05:01 AM
It is working! There was some misspelling or something in configuration, because next morning after good sleep, I tried once again and got running.
Created 02-06-2015 06:36 PM
Created 02-07-2015 05:01 AM
It is working! There was some misspelling or something in configuration, because next morning after good sleep, I tried once again and got running.
Created 11-13-2018 05:39 AM
Hi,
I am facing same error or problem, what was that property you mis-spelled or wrote incorrectly ? Please mention.
Maoj