Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-17-2017 09:26 PM
Hello All - i've HDP 2.5 & HST Server is not starting up ..
the error is as shown below, any ideas ?
------------------------------
java.nio.file.DirectoryNotEmptyException: /var/lib/smartsense/hst-server/updates/upload/patch/var/lib/smartsense/hst-common/anonymization/keys at sun.nio.fs.UnixCopyFile.copy(UnixCopyFile.java:564) at sun.nio.fs.UnixFileSystemProvider.copy(UnixFileSystemProvider.java:253) at java.nio.file.Files.copy(Files.java:1274) at com.hortonworks.support.tools.server.util.ConfigChangeListener.copyDirectorytoDirectory(ConfigChangeListener.java:258) at com.hortonworks.support.tools.server.util.ConfigChangeListener.generatePatch(ConfigChangeListener.java:190) at com.hortonworks.support.tools.server.util.ConfigPatchManager.manageConfigChange(ConfigPatchManager.java:40) at com.hortonworks.support.tools.server.SupportToolServer.run(SupportToolServer.java:300) at com.hortonworks.support.tools.server.SupportToolServer.main(SupportToolServer.java:666) 17 Jul 2017 19:35:04,716 ERROR [main] SupportToolServer:340 - Error stopping the server java.lang.NullPointerException at com.hortonworks.support.tools.server.SupportToolServer.stopBundleCleanupTask(SupportToolServer.java:652) at com.hortonworks.support.tools.server.SupportToolServer.stop(SupportToolServer.java:338) at com.hortonworks.support.tools.server.SupportToolServer.main(SupportToolServer.java:670)
Created 07-17-2017 10:10 PM
@Karan Alang Please try removing /var/lib/smartsense/hst-server/updates/upload/patch first and restart hst server and agents. If you still get the same error the try the same by removing /var/lib/smartsense/hst-server/updates/upload and restart.
Created 07-17-2017 09:28 PM
@Alex Miller, @Young Jin, Park - looping you in, any ideas on this ?
Created 07-17-2017 10:10 PM
@Karan Alang Please try removing /var/lib/smartsense/hst-server/updates/upload/patch first and restart hst server and agents. If you still get the same error the try the same by removing /var/lib/smartsense/hst-server/updates/upload and restart.
Created 07-17-2017 11:11 PM
@Aditya Pathak - thnx, i was able to remove - /var/lib/smartsense/hst-server/updates/upload/patch & start the hst-server & agents.