Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

HTTPS HDFS failed, "unable to find valid certification path to requested target"

avatar
New Member

I've followed steps for each host in https://community.hortonworks.com/articles/52875/enable-https-for-hdfs.html, to enable https for hdfs. Now, I can't enter Files View UI in Ambari and I don't know what problem. Can anybody help me to find a solution? Thanks.

	bigdatamster:50470: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
	2018-08-22 15:37:51,657 INFO BlockStateChange (BlockManager.java:computeReplicationWorkForBlocks(1653)) - BLOCK* neededReplications = 26, pendingReplications = 0. 2018-08-22 15:37:51,657 INFO blockmanagement.BlockManager (BlockManager.java:computeReplicationWorkForBlocks(1660)) - Blocks chosen but could not be replicated = 8; of which 8 have no target, 0 have no source, 0 are UC, 0 are abandoned, 0 already have enough replicas. 2018-08-22 15:37:54,657 INFO BlockStateChange (UnderReplicatedBlocks.java:chooseUnderReplicatedBlocks(395)) - chooseUnderReplicatedBlocks selected 2 blocks at priority level 2; Total=2 Reset bookmarks? true 2018-08-22 15:37:54,658 INFO BlockStateChange (BlockManager.java:computeReplicationWorkForBlocks(1653)) - BLOCK* neededReplications = 26, pendingReplications = 0. 2018-08-22 15:37:54,658 INFO blockmanagement.BlockManager (BlockManager.java:computeReplicationWorkForBlocks(1660)) - Blocks chosen but could not be replicated = 2; of which 2 have no target, 0 have no source, 0 are UC, 0 are abandoned, 0 already have enough replicas.
1 ACCEPTED SOLUTION

avatar
Master Mentor

@Zyann

You will need to make sure that you imported the HDFS certificates to ambari server truststore.

You can refer to the following doc to know more about it:

https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.2.2/bk_ambari-security/content/set_up_truststor...

Choose Option [4] to setup truststore and then next time choose option [5] to import HDFS certification to ambari truststore.

# ambari-server setup-security
.
.
[4] Setup truststore.
[5] Import certificate to truststore.

.

View solution in original post

1 REPLY 1

avatar
Master Mentor

@Zyann

You will need to make sure that you imported the HDFS certificates to ambari server truststore.

You can refer to the following doc to know more about it:

https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.2.2/bk_ambari-security/content/set_up_truststor...

Choose Option [4] to setup truststore and then next time choose option [5] to import HDFS certification to ambari truststore.

# ambari-server setup-security
.
.
[4] Setup truststore.
[5] Import certificate to truststore.

.