Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Hbase Copy table fails for 250 Million Records from a HDP 2.2 ==> HDP 2.4 cluster. Please assist.

avatar
Expert Contributor
Error: org.apache.hadoop.hbase.client.ScannerTimeoutException: 70218ms passed since the last invocation, timeout is currently set to 60000 at org.apache.hadoop.hbase.client.ClientScanner.loadCache(ClientScanner.java:434) at org.apache.hadoop.hbase.client.ClientScanner.next(ClientScanner.java:364) at org.apache.hadoop.hbase.mapreduce.TableRecordReaderImpl.nextKeyValue(TableRecordReaderImpl.java:205) at org.apache.hadoop.hbase.mapreduce.TableRecordReader.nextKeyValue(TableRecordReader.java:147) at org.apache.hadoop.hbase.mapreduce.TableInputFormatBase$1.nextKeyValue(TableInputFormatBase.java:216) at org.apache.hadoop.mapred.MapTask$NewTrackingRecordReader.nextKeyValue(MapTask.java:556) at org.apache.hadoop.mapreduce.task.MapContextImpl.nextKeyValue(MapContextImpl.java:80) at org.apache.hadoop.mapreduce.lib.map.WrappedMapper$Context.nextKeyValue(WrappedMapper.java:91) at org.apache.hadoop.mapreduce.Mapper.run(Mapper.java:145) at org.apache.hadoop.mapred.MapTask.runNewMapper(MapTask.java:787) at
1 ACCEPTED SOLUTION

avatar
Master Collaborator

Default was used.

Please bump it to 90 seconds or higher.

View solution in original post

6 REPLIES 6

avatar
Master Collaborator

Please increase the value for the following parameter:

<name>hbase.client.scanner.timeout.period</name> <value>60000</value>

avatar
Expert Contributor

@Ted Yu Error message shows 60 seconds as default. Do we need to bump it to 90 seconds? thats what you mean? I dont see this property currently set so I guess its taking from default. Please confirm.

avatar
Master Collaborator

Please also check region servers to see if there was critical error during the copy.

avatar
Expert Contributor

@Ted Yu Region servers are good.

avatar
Master Collaborator

Default was used.

Please bump it to 90 seconds or higher.

avatar
Expert Contributor

@Ted Yu Thanks it worked.