Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 06-07-2016 12:12 AM
Error: org.apache.hadoop.hbase.client.ScannerTimeoutException: 70218ms passed since the last invocation, timeout is currently set to 60000 at org.apache.hadoop.hbase.client.ClientScanner.loadCache(ClientScanner.java:434) at org.apache.hadoop.hbase.client.ClientScanner.next(ClientScanner.java:364) at org.apache.hadoop.hbase.mapreduce.TableRecordReaderImpl.nextKeyValue(TableRecordReaderImpl.java:205) at org.apache.hadoop.hbase.mapreduce.TableRecordReader.nextKeyValue(TableRecordReader.java:147) at org.apache.hadoop.hbase.mapreduce.TableInputFormatBase$1.nextKeyValue(TableInputFormatBase.java:216) at org.apache.hadoop.mapred.MapTask$NewTrackingRecordReader.nextKeyValue(MapTask.java:556) at org.apache.hadoop.mapreduce.task.MapContextImpl.nextKeyValue(MapContextImpl.java:80) at org.apache.hadoop.mapreduce.lib.map.WrappedMapper$Context.nextKeyValue(WrappedMapper.java:91) at org.apache.hadoop.mapreduce.Mapper.run(Mapper.java:145) at org.apache.hadoop.mapred.MapTask.runNewMapper(MapTask.java:787) at
Created 06-07-2016 12:30 AM
Created 06-07-2016 12:15 AM
Please increase the value for the following parameter:
<name>hbase.client.scanner.timeout.period</name> <value>60000</value>
Created 06-07-2016 12:21 AM
@Ted Yu Error message shows 60 seconds as default. Do we need to bump it to 90 seconds? thats what you mean? I dont see this property currently set so I guess its taking from default. Please confirm.
Created 06-07-2016 12:16 AM
Please also check region servers to see if there was critical error during the copy.
Created 06-07-2016 12:20 AM
@Ted Yu Region servers are good.
Created 06-07-2016 12:30 AM
Default was used.
Please bump it to 90 seconds or higher.
Created 06-07-2016 01:43 PM
@Ted Yu Thanks it worked.