Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 10-30-2017 01:05 PM - edited 09-16-2022 05:27 AM
Hi,
We have Kerborised Cluster.
I'm able to use the Impala ODBC Driver on a Windows Machine, authenticate with a USERNAME and PASSWORD using SASL.
When I try to connect to the Hive ODBC authenticate with Kerberos. I get the following error message:
FAILED!
[Microsoft][Hardy] (34) Error from server: SASL(-1): generic failure: GSSAPI Error: Unspecified GSS failure. Minor code may provide more information (Server not found in Kerberos database).
Tried:
KRB5_CONFIG = C:\Program Files\MIT\Kerberos5\krb5.ini
KRB5CCNAME =C:\temp\krb5cache
C:\Program Files\MIT\Kerberos5\venkata.keytab
C:\Program Files\MIT\Kerberos5>krb5.ini(config)
[libdefaults]
default_realm = MYKDC.YSTAT.COM
dns_lookup_kdc = false
dns_lookup_realm = false
ticket_lifetime = 86400
renew_lifetime = 604800
forwardable = true
default_tgs_enctypes = aes256-cts aes128-cts
default_tkt_enctypes = aes256-cts aes128-cts
permitted_enctypes = aes256-cts aes128-cts
udp_preference_limit = 1
kdc_timeout = 3000
max_life = 1d
max_renewable_life = 7d
kdc_tcp_ports = 88
ticket_lifetime = 24h
renew_lifetime = 7d
forwardable = true
[realms]MYKDC.YSTAT.COM= {
kdc = dc1.MYKDC.YSTAT.COM
admin_server = dc1.MYKDC.YSTAT.COM
max_renewable_life = 7d 0h 0m 0s
default_principal_flags = +renewable
}
Tried by using different drivers(Simba, Microsoft, Cloudera)Created new users and new keytabs.
Any ideas on this error?
Thanks.
Created 11-06-2017 05:38 AM
It was a problem with KDC admin server has only Private IP.
Now I'm able to connect Hive ODBC by using DBeaver.
Thanks.
Created 10-30-2017 10:10 PM
Created on 11-03-2017 10:21 AM - edited 11-03-2017 10:23 AM
Thanks, @EricL. It was an FQDN issue.
And I've changed FQDN From _Host to HiveServer2.
Now I get the following error message:
FAILED!
[Microsoft][Hardy] (34) Error from server: SSL_connect: unknown protocol.
We are using Centrifydc and windows server on the same Network.
Any ideas on this error?
Thanks again @EricL.
Created 11-06-2017 05:38 AM
It was a problem with KDC admin server has only Private IP.
Now I'm able to connect Hive ODBC by using DBeaver.
Thanks.
Created 11-07-2017 10:51 PM
Created 08-01-2024 10:54 AM
where do we find KDC admin server?How do we find it?
Created 08-01-2024 11:47 AM
@cloudd As this is an older post, you would have a better chance of receiving a resolution by starting a new thread. This will also be an opportunity to provide details specific to your environment that could aid others in assisting you with a more accurate answer to your question. You can link this thread as a reference in your new post. Thanks.
Regards,
Diana Torres,Created 09-27-2021 07:17 AM
You can try by destroying and then cache the kerberos ticket.