Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 10-23-2017 05:19 AM - edited 09-16-2022 05:26 AM
Hi All,
We are getting the error while executing the hive queries with spark engine.
Failed to execute spark task, with exception 'org.apache.hadoop.hive.ql.metadata.HiveException(Failed to create spark client.)'
FAILED: Execution Error, return code 1 from org.apache.hadoop.hive.ql.exec.spark.SparkTask
The following properties are set to use spark as the execution engine instead of mapreduce:
set hive.execution.engine=spark;
set spark.executor.memory=2g;
I tried changing the following properties also.
set yarn.scheduler.maximum-allocation-mb=2048;
set yarn.nodemanager.resource.memory-mb=2048;
set spark.executor.cores=4
set spark.executor.memory=4g;
set spark.yarn.executor.memoryOverhead=750
set hive.spark.client.server.connect.timeout=900000ms;
Created 11-02-2017 04:55 AM
The error was a configuration issue. We need to either lower the executor memory (spark.executor.memory) and executor memory overhead (spark.yarn.executor.memoryOverhead) or increase the maximum memory allocation (yarn.scheduler.maximum-allocation-mb and yarn.nodemanager.resource.memory-mb)
We can refer this link
http://blog.cloudera.com/blog/2015/03/how-to-tune-your-apache-spark-jobs-part-2/
We tried changing all the combinations and the following properties gave the best result in our cluster:
set hive.execution.engine=spark;
set spark.executor.memory=4g;
set yarn.nodemanager.resource.memory-mb=12288;
set yarn.scheduler.maximum-allocation-mb=2048;
Created 10-26-2017 03:57 AM
Created 11-02-2017 04:55 AM
The error was a configuration issue. We need to either lower the executor memory (spark.executor.memory) and executor memory overhead (spark.yarn.executor.memoryOverhead) or increase the maximum memory allocation (yarn.scheduler.maximum-allocation-mb and yarn.nodemanager.resource.memory-mb)
We can refer this link
http://blog.cloudera.com/blog/2015/03/how-to-tune-your-apache-spark-jobs-part-2/
We tried changing all the combinations and the following properties gave the best result in our cluster:
set hive.execution.engine=spark;
set spark.executor.memory=4g;
set yarn.nodemanager.resource.memory-mb=12288;
set yarn.scheduler.maximum-allocation-mb=2048;
Created 11-18-2017 09:02 PM
Created 11-20-2017 03:35 AM
Yes. Just in the hql file. Not anything in XML file