Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Hive service check is failing

avatar
Expert Contributor

Hi,

I'm getting the below issue during hive service check run.

2018-12-06 08:21:38,426 - Running WEBHCAT checks
2018-12-06 08:21:38,426 - ---------------------
.
.
2018-12-06 08:16:07,624 - Retrying after 5 seconds. Reason: Execution of '/var/lib/ambari-agent/tmp/templetonSmoke.sh a767ca44d046.hkc.com ambari-qa 50111 idtest.ambari-qa.1544084165.41.pig /etc/security/keytabs/smokeuser.headless.keytab true /usr/bin/kinit [email protected] /var/lib/ambari-agent/tmp' returned 1. Templeton Smoke Test (ddl cmd): Failed. : {"error":"java.net.ConnectException: Connection refused (Connection refused)"}http_code <500>
Templeton Smoke Test (ddl cmd): Failed. : {"error":"java.net.ConnectException: Connection refused (Connection refused)"}http_code <500>

I tried to execute the below command manually.

[root@a767ca44d046 ~]# /var/lib/ambari-agent/tmp/templetonSmoke.sh a767ca44d046.hkc.com ambari-qa 50111 idtest.ambari-qa.1544084498.43.pig /etc/security/keytabs/smokeuser.headless.keytab true /usr/bin/kinit [email protected] /var/lib/ambari-agent/tmp
Templeton Smoke Test (ddl cmd): Failed. : {"error":"java.net.ConnectException: Connection refused (Connection refused)"}http_code <500>

I have updated the below properties in custom core-site.xml in ambari but did not help.

hadoop.proxyuser.HTTP.hosts=*
hadoop.proxyuser.HTTP.groups=*
webhcat.proxyuser.HTTP.groups=*
webhcat.proxyuser.HTTP.hosts=*

Would you please help on this.

Thank you.

1 ACCEPTED SOLUTION

avatar
Expert Contributor

We have Ranger KMS installed in our cluster. Somehow, ranger kms was in stale config state. I have restarted the Ranger KMS service and hive service check run is fine now.

View solution in original post

1 REPLY 1

avatar
Expert Contributor

We have Ranger KMS installed in our cluster. Somehow, ranger kms was in stale config state. I have restarted the Ranger KMS service and hive service check run is fine now.