Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 09-11-2017 05:28 PM
I downloaded the latest HDP sandbox Docker image and haven't made any configuration changes but HiveServer2 wont start up. I followed the instructions here: https://hortonworks.com/tutorial/learning-the-ropes-of-the-hortonworks-sandbox/
The error I'm getting from ambari is:
resource_management.core.exceptions.ExecutionFailed: Execution of 'curl -sS -L -w '%{http_code}' -X GET 'http://sandbox.hortonworks.com:50070/webhdfs/v1/user/hcat?op=GETFILESTATUS&user.name=hdfs' 1>/tmp/tmp8jppwO 2>/tmp/tmplTA4jO' returned 7. curl: (7) couldn't connect to host
000
This is the last error I'm getting from ambari server logs:
[ERROR] [09/11/2017 17:14:37.184] [HiveViewActorSystem-akka.actor.jdbc-connector-dispatcher-7] [akka://HiveViewActorSystem/user/7f19f4e8-f652-43ff-9c60-7a73ba2d4892:syncjdbcConnector] null java.lang.NullPointerException at org.apache.ambari.view.hive2.actor.JdbcConnector.postStop(JdbcConnector.java:611)
The hive logs just say connection refused.
I'm not sure if its a docker issue or something on sandbox. Any help would be appreciated.
Created 09-12-2017 01:17 AM
I fixed the issue, it seems stopping all of the services and then bringing them up one by one seems to fix it. Specifically I started HDFS, Zookeeper, Yarn, MapReduce2, Tez, then finally Hive. Still not sure what the problem was, I'm guessing one of the other services was blocking hive somehow.
Created 09-11-2017 10:45 PM
Successfully, I was able to deploy HDP 2.6.1 sandbox (Docker) on MacOS.
Which OS are you using?
Can you please confirm MD5 for your downloaded file is 745d557ba182e401158fff914829cade.
Created 09-12-2017 01:19 AM
I'm on windows and the MD5 matches. I think we fixed the issue but we had to stop all the services first.
Created 09-12-2017 01:17 AM
I fixed the issue, it seems stopping all of the services and then bringing them up one by one seems to fix it. Specifically I started HDFS, Zookeeper, Yarn, MapReduce2, Tez, then finally Hive. Still not sure what the problem was, I'm guessing one of the other services was blocking hive somehow.