Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 04-12-2017 06:48 PM
hiveserver2-notstartingup-1.pdf
Hi All - I've an 8 Node HDP 2.5.3 cluster, and Hive is installed on Node-6. From Ambari - Hiveserver 2 is not startup, it gives the following error (as shown on the Ambari UI)
---------------------------------------------------------------------------------------
Connection failed on host <Node7>:10000
(Traceback (most recent call last): File "/var/lib/ambari-agent/cache/common-services/HIVE/0.12.0.2.0/package/alerts/alert_hive_thrift_port.py", line 200, in execute check_command_timeout=int(check_command_timeout)) File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/hive_check.py", line 74, in check_thrift_port_sasl timeout=check_command_timeout) File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 155, in __init__ self.env.run() File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 160, in run self.run_action(resource, action) File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 124, in run_action provider_action() File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 273, in action_run tries=self.resource.tries, try_sleep=self.resource.try_sleep) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 70, in inner result = function(command, **kwargs) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 92, in checked_call tries=tries, try_sleep=try_sleep) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 140, in _call_wrapper result = _call(command, **kwargs_copy) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 293, in _call raise ExecutionFailed(err_msg, code, out, err)
ExecutionFailed: Execution of '! beeline -u 'jdbc:hive2://<Node7>:10000/;transportMode=binary' -e '' 2>&1| awk '{print}'|grep -i -e 'Connection refused' -e 'Invalid URL'' returned 1. Error: Could not open client transport with JDBC Uri: jdbc:hive2://nwk2-bdp-hadoop-07.gdcs-qa.apple.com:10000/;transportMode=binary: java.net.ConnectException:
Connection refused (Connection refused) (state=08S01,code=0) Error: Could not open client transport with JDBC Uri: jdbc:hive2://<Node-7>:10000/;transportMode=binary: java.net.ConnectException: Connection refused (Connection refused) (state=08S01,code=0) )
---------------------------------------------------------------------------------------------
Pls note -> In the above error, it is trying to connect to Node-7, instead of Node-6
When i start HiveServer2 on commandline from Node-6, i'm able to start it & connect to Hive using Beeline.
Any ideas where the issue is ?
Attaching the HiveServer.log & the hive-site.xml as well.
Created 04-14-2017 07:52 PM
you are getting invalid url. Shouldn't the url start with '!connect jdbc:hive2://<host>:<port>/<db>'
Created 04-12-2017 07:15 PM
@Pardeep, @Kuldeep Kulkarni, @Jitendra Yadav - looping you in, any ideas on this ?
Created 04-12-2017 09:24 PM
@Artem Ervits, @vpoornalingam, @Mark Herring - looping you in, any ideas on this ?
Created 04-14-2017 07:30 PM
@mqureshi - looping you in, pls. let me know if you have any ideas on this... thnx
Created 04-14-2017 07:52 PM
you are getting invalid url. Shouldn't the url start with '!connect jdbc:hive2://<host>:<port>/<db>'
Created 04-19-2017 04:25 AM
@mqureshi - the issue was that /tmp/hive had incorrect permissions, similar issue was recorded in