Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Hiveserver2 failing with /tmp/tmp23xNhA 2>/tmp/tmpyf2fO3' returned 2. curl: option --negotiate: the installed libcurl version doesn't support this curl: try 'curl --help' or 'curl --manual' for more information>

avatar
Rising Star

Hi Folks ,

Please help in resolving the error . I am getting the below error when hiveserver2 restarted .

In My HWX cluster I have Hive metastore in Control node and 4 hiveserver2 running on 4 edge nodes . All the hiveservers are running good except on one edge node failing with below error .

resource_management.core.exceptions.Fail: Execution of 'curl -sS -L -w '%{http_code}' -X GET --negotiate -u : 'http://hdp-iaas-dev29-control1.dev.na1.phsdp.com:50070/webhdfs/v1/user/hcat?op=GETFILESTATUS&user.name=hdfs' 1>/tmp/tmp23xNhA 2>/tmp/tmpyf2fO3' returned 2. curl: option --negotiate: the installed libcurl version doesn't support this
curl: try 'curl --help' or 'curl --manual' for more information

1 ACCEPTED SOLUTION

avatar
Master Guru

Update your libcurl and curl on those machines.

View solution in original post

1 REPLY 1

avatar
Master Guru

Update your libcurl and curl on those machines.