Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

HostCleanup.py failing

avatar
Super Collaborator

i am trying to cleanup the existing cluster for new install but this script fails with the following error:

[root@hadoop1 ambari_agent]# python HostCleanup.py --help
  File "HostCleanup.py", line 111
    except Exception, err:
                    ^
SyntaxError: invalid syntax
1 ACCEPTED SOLUTION

avatar
Master Mentor

@Sami Ahmad Which exact version of ambari are you using?

I do not see any matching line at 111 on that script of Ambari 2.2.2 / 2.4.0/ 2.4.2/ 2.5.0 versions of API.

https://github.com/apache/ambari/blob/release-2.5.0/ambari-agent/src/main/python/ambari_agent/HostCl...

https://github.com/apache/ambari/blob/release-2.4.2/ambari-agent/src/main/python/ambari_agent/HostCl...

https://github.com/apache/ambari/blob/release-2.2.2/ambari-agent/src/main/python/ambari_agent/HostCl...

- I see line 111 is empty. (So i am suspecting that the script that you are using might be slightly changed/edited).

16409-line-111.png

So by any chance have you made any modification to this script?

# /usr/lib/python2.6/site-packages/ambari_agent/HostCleanup.py

.

- What is your python version?

- If you continue to face this issue then it will be quick to "Uninstall ambari-agent" and then install it back after manually cleaning up the agent directories.

# yum remove ambari-agent 
# yum install ambari-agent

.

View solution in original post

2 REPLIES 2

avatar
Master Mentor

@Sami Ahmad Which exact version of ambari are you using?

I do not see any matching line at 111 on that script of Ambari 2.2.2 / 2.4.0/ 2.4.2/ 2.5.0 versions of API.

https://github.com/apache/ambari/blob/release-2.5.0/ambari-agent/src/main/python/ambari_agent/HostCl...

https://github.com/apache/ambari/blob/release-2.4.2/ambari-agent/src/main/python/ambari_agent/HostCl...

https://github.com/apache/ambari/blob/release-2.2.2/ambari-agent/src/main/python/ambari_agent/HostCl...

- I see line 111 is empty. (So i am suspecting that the script that you are using might be slightly changed/edited).

16409-line-111.png

So by any chance have you made any modification to this script?

# /usr/lib/python2.6/site-packages/ambari_agent/HostCleanup.py

.

- What is your python version?

- If you continue to face this issue then it will be quick to "Uninstall ambari-agent" and then install it back after manually cleaning up the agent directories.

# yum remove ambari-agent 
# yum install ambari-agent

.

avatar
Super Collaborator

thanks Jay , reinstalling agent fixed this script.

I will go ahead and deinstall the cluster using this script and then try to reinstall again.

my cluster was running f ine until I deinstalled it and since then I am unable to get it up and running .