Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

How to resolve `java.net.BindException: Address already in use` error while accesing kafka connect in Apache kafka ?

avatar
New Member

When trying to use kafka connect using following command :

bin/connect-standalone.sh config/connect-standalone.properties config/connect-file-source.properties config/connect-file-sink.properties

It throws a error as
`WARN FAILED http_8083@773e2eb5{HTTP/1.1}{0.0.0.0:8083}: java.net.BindException: Address already in use (org.eclipse.jetty.util.component.AbstractLifeCycle:212)`

and finally ends with the line `INFO Kafka Connect stopped`

How can I change my Kafka-Connect port from 8083 to other port ?

1 ACCEPTED SOLUTION

avatar

@Rahul Kumar You can change the port by adding:

rest.port=<port>

To the config/connect-standalone.properties

HTH

*** If you found this answer addressed your question, please take a moment to login and click the "accept" link on the answer.

View solution in original post

5 REPLIES 5

avatar

Hey @Rahul Kumar!
You can change this in connect-standalone.properties

Should have a property called rest.port 🙂

or if you're planning to use kafka connect in the cluster mode, you should find this parameter in connect-distributed worker.properties

Hope this helps!

avatar

@Rahul Kumar You can change the port by adding:

rest.port=<port>

To the config/connect-standalone.properties

HTH

*** If you found this answer addressed your question, please take a moment to login and click the "accept" link on the answer.

avatar
New Member

its working Thank you experts @Felix Albani and @Vinicius Higa Murakami

avatar

Good to know @Rahul Kumar!
I already used in cluster mode and it's quite good as well.
So keep going on this! It's an interesting feature from kafka

PS: I'm not an expert yet haha, just a humble guy trying to help xD
Let us know if you have more questions! 🙂

avatar
New Member

@Vinicius I m right now at a beginner stage of learning kafka. Just running a single instance on my local system ...havn't thought of working on clusters. But It is nice to get in touch with u and enhance my knowledge.

Thanks once again 🙂