Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 06-14-2016 07:09 AM
When clicking on Hive view from views tab in ambari i am getting "500: server error".
Please help me on this.
Thanks in advance!
Created 06-16-2016 09:19 AM
@Sagar Shimpi Thanks a lot 🙂
It was resolved by changing the AMBARI_JVM_ARGS variable in /var/lib/ambari-server/ambari-env.sh, by replacing the default -Xmx2048mwith the following:
-Xmx4096m -XX:PermSize=128m -XX:MaxPermSize=128m
Created 06-14-2016 03:03 PM
@Raghu Ramamoorthi Can you let us know which link you followed for HIVE view installation ? Can you check ambari-server logs for fore error log details
Created 06-15-2016 02:09 PM
Hi Sagar i just navigated to ambari views and created Hive View.
The ambari-server log says that:
Jun 15, 2016 12:59:48 AM com.sun.jersey.spi.inject.Errors processErrorMessages WARNING: The following warnings have been detected with resource and/or provider classes: WARNING: A HTTP GET method, public javax.ws.rs.core.Response org.apache.ambari.server.api.services.HostComponentService.getHostComponents(java.lang.String,javax.ws.rs.core.HttpHeaders,javax.ws.rs.core.UriInfo), should not consume any entity. WARNING: A HTTP GET method, public javax.ws.rs.core.Response org.apache.ambari.server.api.services.HostComponentService.getHostComponent(java.lang.String,javax.ws.rs.core.HttpHeaders,javax.ws.rs.core.UriInfo,java.lang.String,java.lang.String), should not consume any entity. Exception in thread "Server Action Executor" Exception: java.lang.OutOfMemoryError thrown from the UncaughtExceptionHandler in thread "Server Action Executor" Exception in thread "alert-event-bus-2" Exception in thread "alert-event-bus-1" java.lang.OutOfMemoryError: PermGen space java.lang.OutOfMemoryError: PermGen space Jun 15, 2016 10:02:55 AM com.sun.jersey.spi.container.ContainerResponse mapMappableContainerException SEVERE: The exception contained within MappableContainerException could not be mapped to a response, re-throwing to the HTTP container java.lang.OutOfMemoryError: PermGen space Jun 15, 2016 10:02:55 AM com.sun.jersey.spi.container.ContainerResponse mapMappableContainerException SEVERE: The exception contained within MappableContainerException could not be mapped to a response, re-throwing to the HTTP container java.lang.OutOfMemoryError: PermGen space
Please assist me.
Thanks in advance.!
Created 06-15-2016 03:07 PM
It clearly say its OutOfMemory issue "java.lang.OutOfMemoryError: PermGen space java.lang.OutOfMemoryError: PermGen space"
Pls check this to resolve the issue - https://docs.hortonworks.com/HDPDocuments/Ambari-2.1.2.0/bk_ambari_views_guide/content/ch_preparing_...
Created 06-16-2016 09:18 AM
@Sagar Shimpi Thanks a lot 🙂
It was resolved by changing the AMBARI_JVM_ARGS variable in /var/lib/ambari-server/ambari-env.sh, by replacing the default -Xmx2048m with the following:
-Xmx4096m -XX:PermSize=128m -XX:MaxPermSize=128m
Created 06-16-2016 09:19 AM
@Sagar Shimpi Thanks a lot 🙂
It was resolved by changing the AMBARI_JVM_ARGS variable in /var/lib/ambari-server/ambari-env.sh, by replacing the default -Xmx2048mwith the following:
-Xmx4096m -XX:PermSize=128m -XX:MaxPermSize=128m
Created 11-02-2017 07:14 AM
@Sagar Shimpi Thanks a lot 🙂
It was resolved by changing the AMBARI_JVM_ARGS variable in /var/lib/ambari-server/ambari-env.sh, by replacing the default -Xmx2048m with the following:
-Xmx4096m -XX:PermSize=128m -XX:MaxPermSize=128m