Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

How to solve buffer memory issue in Solr

avatar
Guru

Team,

When I am creating collection with two shards and 2 replication then I am getting buffer memory issue. So can you please help me how to increasing it or by setting other property.

[solr@m1 solr]$ /opt/lucidworks-hdpsearch/solr/bin/solr create -c test -d /opt/lucidworks-hdpsearch/solr/server/solr/configsets/data_driven_schema_configs_hdfs/conf -n test -s 2 -rf 2

Connecting to ZooKeeper at m1.hdp22:2181,m2.hdp22:2181,w1.hdp22:2181

Uploading /opt/lucidworks-hdpsearch/solr/server/solr/configsets/data_driven_schema_configs_hdfs/conf for config test to ZooKeeper at m1.hdp22:2181,m2.hdp22:2181,w1.hdp22:2181

Creating new collection 'test' using command:

http://192.168.56.42:8983/solr/admin/collections?action=CREATE&name=test&numShards=2&replicationFact...

{

"responseHeader":{

"status":0,

"QTime":4812},

"failure":{"":"org.apache.solr.client.solrj.impl.HttpSolrClient$RemoteSolrException:Error from server at http://192.168.56.41:8983/solr: Error CREATEing SolrCore 'test_shard1_replica1': Unable to create core [test_shard1_replica1] Caused by: Direct buffer memory"},

"success":{"":{

"responseHeader":{

"status":0,

"QTime":4659},

"core":"test_shard2_replica1"}}}

1 ACCEPTED SOLUTION

avatar
Guru

I have solved it by setting up <boolname="solr.hdfs.blockcache.direct.memory.allocation">false</bool> in solrconfig.xml file.

View solution in original post

1 REPLY 1

avatar
Guru

I have solved it by setting up <boolname="solr.hdfs.blockcache.direct.memory.allocation">false</bool> in solrconfig.xml file.