Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 09-20-2016 12:51 PM
Hi everyone!
I am trying to create a cluster and in the "step 8 : Review" I get the next error when I click on the "Deploy -->" button:
"Upload Version Definition File Error"
"An internal system exception occurred: Base url http://public-repo-1.hortonworks.com/HDP/sles12/2.x/updates/2.5.0.0 is already defined for another repository version. Setting up base urls that contain the same versions of components will cause stack upgrade to fail."
What does it happen? What can I do to solve the problem?
Thank you so much!
Created 09-20-2016 02:40 PM
Finally I solved the problem following these steps:
First of all, I stopped the ambari-server service from the host where it is installed, and I proceed to reset it, using the command:
ambari-server stop
ambari-service reset
Then I cleaned the cache information of the web browser I was using to connect to the Ambari Installation Wizard.
After that, I restart the ambari-server and I tried to install the cluster again.
Thank you for your answers anyway!
Created 02-09-2017 02:13 AM
remove the old ambari database. create now ambari database.
Created 03-23-2017 04:34 PM
Hi All,
I am having this same issue and I have tried some of the recommendations above with negative results. I am trying to stand up an HDP 2.4 cluster on centos7. In my experience, I get passed all of the assigning of roles to my name and datanodes and hit deploy. Everything looks like it's going smoothly and then I get smacked with the "Upload Version Definition File Error". At this point things are stalled. I check to see if my ambari-server is still running and it isn't. I try to restart it and I get a postgres "exit code 3. REASON: Unable to start PostgreSQL server". I've tried to reset the server, dump the database, un/re-install ambari-server, and even select the other than default postgres during the setup with same result. Can anyone help? Thanks.