Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 05-30-2016 09:00 AM
I have been working on scheduling HBase compaction using oozie. I ran into this error message and i have changed permissions, used a different users and also specified in the <exec> and <file> parameters the script but it keeps failing with error message "Cannot run program "minorcompaction.sh" (in directory "/hadoop/yarn/local/usercache/yarn/appcache/application_1464245207716_0007/container_e28_1464245207716_0007_01_000002"): error=2, No such file or directory" but i have not been able to get past this issue. Any help?
Created 08-01-2016 07:14 AM
Changing from Oracle 12c to MySQL resolved this issue.
Created 05-30-2016 09:30 AM
It would sound to me that you didnt use the file tag correctly. Did you upload the file to hdfs? However I am dubious if this will work in any case since the script will have a lot of dependencies. You might have to install the hbase client on all nodes or upload a lot of extra libraries.
Alternatively you could use an ssh action to connect to a full working edge node and run your commands there. I would almost propose this for something non mission critical like scheduling compactions.
Created 06-01-2016 01:50 PM
Created 06-01-2016 03:40 PM
Weird I do the same thing and it should work. Works for me. You sure its not just a stupid mistake like missing / or that the access rights are not correct? Can you try with hardcoded path?
<exec>myscript.sh</exec>
...
<file>${nameNode}/myfolder/myscript.sh#myscript.sh</file>
Created 06-02-2016 05:33 AM
Hi @BenjaminLeonhardi, I am getting another error message. What can be wrong with the permissions? Cannot run program "minorcompaction.sh" (in directory "/hadoop/yarn/local/usercache/hdfs/appcache/application_1462434761155_14999/container_e12_1462434761155_14999_01_000002"): error=13, Permission denied.
Created 06-02-2016 06:08 AM
I've also tried the hardcoded path, not working still. I am trying on two platforms and getting different errors.
Created 08-01-2016 07:14 AM
Changing from Oracle 12c to MySQL resolved this issue.