Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 09-28-2016 11:00 AM
[root@hdp ~]# ambari-server start Using python /usr/bin/python2 Starting ambari-server Ambari Server running with administrator privileges. Organizing resource files at /var/lib/ambari-server/resources... Server PID at: /var/run/ambari-server/ambari-server.pid Server out at: /var/log/ambari-server/ambari-server.out Server log at: /var/log/ambari-server/ambari-server.log Waiting for server start.................... ERROR: Exiting with exit code -1. REASON: Ambari Server java process died with exitcode 1. Check /var/log/ambari-server/ambari-server.out for more information. [root@hdp ~]# ambari-agent start Verifying Python version compatibility... Using python /usr/bin/python2 Checking for previously running Ambari Agent... ERROR: ambari-agent already running Check /var/run/ambari-agent/ambari-agent.pid for PID. [root@hdp ~]# ambari-agent status Found ambari-agent PID: 3126 ambari-agent running. Agent PID at: /var/run/ambari-agent/ambari-agent.pid Agent out at: /var/log/ambari-agent/ambari-agent.out Agent log at: /var/log/ambari-agent/ambari-agent.log
Created 09-28-2016 11:03 AM
As per the error, you need to check the logs to understand what's happening. The log is /var/log/ambari-server/ambari-server.log
If it doesn't make sense - don't hesitate to post them here.
Created 09-28-2016 11:03 AM
As per the error, you need to check the logs to understand what's happening. The log is /var/log/ambari-server/ambari-server.log
If it doesn't make sense - don't hesitate to post them here.
Created 09-28-2016 12:09 PM
log file:
Created 09-28-2016 06:43 PM
Hi @ANSARI FAHEEM AHMED ,
looks like you are using MySQL as underlying db, and you need to set property 'max_allowed_packet' in mysql config file.
With a default installation, it would be in file /etc/my.cnf , where you can add/set the property like e.g.:
max_allowed_packet=256M
Then restart mysql and give the ambar-server start another try.
HTH, best regards
Created 09-30-2016 10:03 AM
Dear Gerd, I have set the above line in my.cnf file and restart mysqld but have same issue
[root@hdp etc]# vi my.cnf [root@hdp etc]# sudo systemctl restart mysqld
[root@hdp /]# ambari-server start
Using python /usr/bin/python2 Starting ambari-server Ambari Server running with administrator privileges. Organizing resource files at /var/lib/ambari-server/resources... Server PID at: /var/run/ambari-server/ambari-server.pid Server out at: /var/log/ambari-server/ambari-server.out Server log at: /var/log/ambari-server/ambari-server.log Waiting for server start.................... Ambari Server 'start' completed successfully.
[root@hdp /]# ambari-server status
Using python /usr/bin/python2 Ambari-server status Ambari Server not running. Stale PID File at: /var/run/ambari-server/ambari-server.pid