Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-08-2016 03:29 PM
Here my command :
curl -u admin:Password -H "X-Requested-By:ambari" -i -X PUT -d '{"RequestInfo":{"context":"Stop NODEMANAGER"}, "Body":{"HostRoles":{"state":"INSTALLED"}}}' http://viceroy10:8080/api/v1/clusters/et_cluster/hosts/serf120int.etops.tllsc.net/host_components/NO...
Thank you in advance.
Created 03-08-2016 08:34 PM
curl -u admin:password -i -H 'X-Requested-By: ambari' -X PUT -d '{"RequestInfo":{"context":"Stop NODEMANAGER"}, "Body":{"HostRoles": {"state": "INSTALLED"}}}' http://viceroy10:8080/api/v1/clusters/et_cluster/hosts/$hostname/host_components/NODEMANAGER
Created 03-08-2016 04:02 PM
Once accepted, did it start a job in the Ambari Ops? Please check for any errors in the Ambari Opts listing for this job. Also tail ambari-server.log for this period and observe if any error is reported related to this curl command.
Created 03-08-2016 06:12 PM
It got worked for me with the following command :.
curl -u admin:password -i -H 'X-Requested-By: ambari' -X
PUT -d '{"RequestInfo":{"context":"Stop
NODEMANAGER"}, "Body":{"HostRoles":
{"state": "INSTALLED"}}}' http://viceroy10:8080/api/v1/clusters/et_cluster/hosts/$hostname/host_components/NODEMANAGER
I dont know what is the difference between both commands?
Created 03-08-2016 06:18 PM
@Ram D keep your passwords safe
Created 03-08-2016 08:34 PM
curl -u admin:password -i -H 'X-Requested-By: ambari' -X PUT -d '{"RequestInfo":{"context":"Stop NODEMANAGER"}, "Body":{"HostRoles": {"state": "INSTALLED"}}}' http://viceroy10:8080/api/v1/clusters/et_cluster/hosts/$hostname/host_components/NODEMANAGER