Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 04-06-2016 08:38 AM - edited 09-16-2022 03:12 AM
Hi ,
After install a load balancer with ssl for impala, all the impala deamons are generating many messages on each log with the following description : "INFO thrift-util.cc:109 TThreadPoolServer: TServerTransport died on accept: SSL_accept: error code: 0"
we can have a lot messages per second, and it never stops.
This message is part of a health test or something like that ?
What can i do to check something wrong with my conection to the load balancer?
Log example :
Apr 6, 10:10:53.549 AM INFO thrift-util.cc:109 TThreadPoolServer: TServerTransport died on accept: SSL_accept: error code: 0
Apr 6, 10:10:53.937 AM INFO thrift-util.cc:109 TThreadPoolServer: TServerTransport died on accept: SSL_accept: error code: 0
Apr 6, 10:10:54.037 AM INFO thrift-util.cc:109 TThreadPoolServer: TServerTransport died on accept: SSL_accept: error code: 0
Created 04-11-2016 06:37 AM
Hi,
We reviewed the configuration of the Impala service and removed an extraneous role group containing only a single Impala daemon node. After restarting the Impala service and re-deploying the client configurations, ODBC clients connected successfully through the HAProxy load balancer .
Cloudera support help me with this issue reported on the case 91228.
Thanks
Created 04-06-2016 10:14 PM
This usually means that SSL is configured badly - is your load balancer and / or client configured to make an SSL connection to Impala?
The repeated connections are a mystery - they're coming from the client RPC port. So maybe something is using your load balancer repeatedly? Or is the LB itself attempting to create a set of connections (maybe to warm up its connection pool)?
Created on 04-07-2016 01:22 PM - edited 04-07-2016 01:23 PM
Hi Henry,
Thanks for your suppport and interest.
These are the answers for your questions:
1. Yes, we are trying to make an SSL connection to Impala, however , we don't know if we need to change something. Do you know some test or steps to check this ?
2. We don't now if a client are trying to check the connection, so, how i can check this ? I can't find an other log with more information or clues to identify the problem.
3.The LB does not have any health test or something like that, only manage the conections from/to CDH.
Created 04-07-2016 02:22 PM
You will need to tell your client (is it shell, JDBC or something else?) to use SSL. Have you read http://www.cloudera.com/documentation/archive/impala/2-x/2-0-x/topics/impala_ssl.html? The instructions for the shell are at the bottom of that pa
Created 04-11-2016 06:37 AM
Hi,
We reviewed the configuration of the Impala service and removed an extraneous role group containing only a single Impala daemon node. After restarting the Impala service and re-deploying the client configurations, ODBC clients connected successfully through the HAProxy load balancer .
Cloudera support help me with this issue reported on the case 91228.
Thanks