Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 07-06-2017 06:01 AM - edited 09-16-2022 04:53 AM
I downloaded the quickstart VM for Windows and I’ve managed to create Hive table with 20 odd million rows based on a set of large CSVs, but I’m a bit stuck with Impala as it doesn’t seem to work out of the box.
I can see my Hive table in the navigation pane on the left, but when I try and interact with Impala I get this:
“Could not connect to quickstart.cloudera:21050 (code THRIFTTRANSPORT): TTransportException('Could not connect to quickstart.cloudera:21050',)”
I found some forum postings saying to check the impala services are running, and they weren’t. If I start them they start and then fail. The culprit seems to be the statestore which has this in the log:
“Log file created at: 2017/07/06 04:25:34
Running on machine: quickstart.cloudera
Log line format: [IWEF]mmdd hh:mm:ss.uuuuuu threadid file:line] msg
E0706 04:25:34.694190 13778 logging.cc:121] stderr will be logged to this file.
E0706 04:25:34.770515 13821 thrift-server.cc:182] ThriftServer 'StatestoreService' (on port: 24000) exited due to TException: Could not create server socket.: Address family not supported by protocol
E0706 04:25:34.771359 13778 thrift-server.cc:171] ThriftServer 'StatestoreService' (on port: 24000) did not start correctly
F0706 04:25:34.771697 13778 statestored-main.cc:89] ThriftServer 'StatestoreService' (on port: 24000) did not start correctly
. Impalad exiting.
*** Check failure stack trace: ***
@ 0x1b5572d (unknown)
@ 0x1b58056 (unknown)
@ 0x1b5524d (unknown)
@ 0x1b58afe (unknown)
@ 0xb48be0 (unknown)
@ 0x7d17dc (unknown)
@ 0x3389c1ed5d (unknown)
@ 0x80257d (unknown)
Wrote minidump to /var/log/impala/minidumps/statestored/748cf330-58ba-037c-346a2772-2ac43d8e.dmp”
I checked the forums but I didn’t find anything useful to help fix this.
Can anyone help?
Cheers,
Steve
Created 07-14-2017 02:38 AM
After a bit of googling I managed to figure it out. I found out that my VM didnt have any Internet access, and after lots of messing around trying to figure out why the vmWare Bridge adapter wasn't working, I found other people had found the vmWare installation didn't manage to install the bridge adapter correctly due to anti-virus software detecting it as malware. I dont remember seeing any errors during installation, but I reinstalled vmWare from scratch with my anti-virus software disabled and the bridge adapter worked fine. IPv6 was enabled on the QuickStart VM and then Impala worked fine.
Created 07-06-2017 10:50 AM
Created 07-14-2017 02:38 AM
After a bit of googling I managed to figure it out. I found out that my VM didnt have any Internet access, and after lots of messing around trying to figure out why the vmWare Bridge adapter wasn't working, I found other people had found the vmWare installation didn't manage to install the bridge adapter correctly due to anti-virus software detecting it as malware. I dont remember seeing any errors during installation, but I reinstalled vmWare from scratch with my anti-virus software disabled and the bridge adapter worked fine. IPv6 was enabled on the QuickStart VM and then Impala worked fine.
Created 07-14-2017 05:49 AM
Congratulations on finding solving this one. I do believe this is the first time I have heard of antivirus software causing an issue on the QuickStart VM. I'll have to read up on that a bit myself. Thanks for sharing. 🙂
Created 07-14-2017 05:55 AM
Created 07-14-2017 06:02 AM
Ah, yes. I should have been clearer in my wording. I meant the VM itself. 🙂
Created 07-14-2017 05:56 AM
@stevearcherDid you try switching on the anti-virus software after you brought up your vm and impala ? Just curious to know
Created 07-14-2017 06:02 AM