Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 04-27-2017 12:37 AM - edited 09-16-2022 04:31 AM
Below is the error while adding zookeeper to one of the node.
+ ZOOKEEPER_SERVER_OPTS='-Djava.net.preferIPv4Stack=true -Dzookeeper.log.file=zookeeper-cmf-zookeeper-SERVER-hdp-poc-d1.vmware.com.log -Dzookeeper.log.dir=/var/log/zookeeper -Dcom.sun.management.jmxremote.port=9010 -Dcom.sun.management.jmxremote.rmi.port=9010 -Dcom.sun.management.jmxremote.authenticate=false -Dcom.sun.management.jmxremote.ssl=false -Djute.maxbuffer=4194304 -Dzookeeper.datadir.autocreate=false -Xms784334848 -Xmx784334848 -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp/zookeeper_zookeeper-SERVER-153098168435d1b55999a6d815852712_pid44416.hprof -XX:OnOutOfMemoryError=/usr/lib64/cmf/service/common/killparent.sh'
+ exec /usr/java/jdk1.7.0_67-cloudera/bin/java -cp '/run/cloudera-scm-agent/process/375-zookeeper-server:/opt/cloudera/parcels/CDH-5.11.0-1.cdh5.11.0.p0.34/lib/zookeeper/lib/log4j.jar:/opt/cloudera/parcels/CDH-5.11.0-1.cdh5.11.0.p0.34/lib/zookeeper/build/*:/opt/cloudera/parcels/CDH-5.11.0-1.cdh5.11.0.p0.34/lib/zookeeper/build/lib/*:/opt/cloudera/parcels/CDH-5.11.0-1.cdh5.11.0.p0.34/lib/zookeeper/*:/opt/cloudera/parcels/CDH-5.11.0-1.cdh5.11.0.p0.34/lib/zookeeper/lib/*:/usr/share/cmf/lib/plugins/event-publish-5.11.0-shaded.jar:/usr/share/cmf/lib/plugins/tt-instrumentation-5.11.0.jar' -Djava.net.preferIPv4Stack=true -Dzookeeper.log.file=zookeeper-cmf-zookeeper-SERVER-hdp-poc-d1.vmware.com.log -Dzookeeper.log.dir=/var/log/zookeeper -Dcom.sun.management.jmxremote.port=9010 -Dcom.sun.management.jmxremote.rmi.port=9010 -Dcom.sun.management.jmxremote.authenticate=false -Dcom.sun.management.jmxremote.ssl=false -Djute.maxbuffer=4194304 -Dzookeeper.datadir.autocreate=false -Xms784334848 -Xmx784334848 -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp/zookeeper_zookeeper-SERVER-153098168435d1b55999a6d815852712_pid44416.hprof -XX:OnOutOfMemoryError=/usr/lib64/cmf/service/common/killparent.sh org.apache.zookeeper.server.quorum.QuorumPeerMain /run/cloudera-scm-agent/process/375-zookeeper-server/zoo.cfg
Error: Exception thrown by the agent : java.lang.NullPointerException
Created 04-27-2017 09:12 AM
Oh, and we have had this sort of thing happen if the port specified in "com.sun.management.jmxremote.rmi.port=9010" is already in use. You may want to try "netstat -nap|grep 9010" to see if another process has taken that port.
Ben
Created 04-27-2017 08:58 AM
Created 04-27-2017 09:07 AM
Since the stderr.log shows that the supervisor already tried starting Zookeeper and the agent/supervisor is written in python, the exception must be coming from Zookeeper itself. I'd recommend checking the zookeeper logs on the host where it failed to start. Also you might check "stdout.log" for the process as it sometimes contains output including role exceptions.
-Ben
Created 04-27-2017 09:12 AM
Oh, and we have had this sort of thing happen if the port specified in "com.sun.management.jmxremote.rmi.port=9010" is already in use. You may want to try "netstat -nap|grep 9010" to see if another process has taken that port.
Ben
Created 04-28-2017 12:59 AM
Thanks Ben,
issue got fixed.
Created 03-29-2018 01:52 AM
Hey I am getting the same error. Can you help?
Created 04-27-2017 09:16 AM
One more lastly:
"Exception thrown by the agent" is not from Cloudera's Agent; rather it is the RMI Agent I believe and a web search confirms that the error you see is when the RMI port is taken