Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 04-29-2014 04:09 AM - edited 04-29-2014 04:50 AM
Hi Folks,
I'm facing an issue with HDFS starting.
I installed CDH5 with 3 servers. I put 2 of them as Datanodes.
When i try to launch HDFS service on datanode servers i got the error bellow (stderr):
+ '[' -e /var/run/cloudera-scm-agent/process/317-hdfs-DATANODE/topology.py ']'
+ '[' -e /var/run/cloudera-scm-agent/process/317-hdfs-DATANODE/log4j.properties ']'
+ perl -pi -e 's#{{CMF_CONF_DIR}}#/var/run/cloudera-scm-agent/process/317-hdfs-DATANODE#g' /var/run/cloudera-scm-agent/process/317-hdfs-DATANODE/log4j.properties
++ find /var/run/cloudera-scm-agent/process/317-hdfs-DATANODE -maxdepth 1 -name '*.py'
+ OUTPUT=
+ '[' '' '!=' '' ']'
+ '[' DATANODE_MAX_LOCKED_MEMORY '!=' '' ']'
+ ulimit -l
+ export HADOOP_IDENT_STRING=hdfs
+ HADOOP_IDENT_STRING=hdfs
+ '[' -n '' ']'
+ acquire_kerberos_tgt hdfs.keytab
+ '[' -z hdfs.keytab ']'
+ '[' -n '' ']'
+ '[' validate-writable-empty-dirs = datanode ']'
+ '[' file-operation = datanode ']'
+ '[' bootstrap = datanode ']'
+ '[' failover = datanode ']'
+ '[' transition-to-active = datanode ']'
+ '[' initializeSharedEdits = datanode ']'
+ '[' initialize-znode = datanode ']'
+ '[' format-namenode = datanode ']'
+ '[' monitor-decommission = datanode ']'
+ '[' jnSyncWait = datanode ']'
+ '[' nnRpcWait = datanode ']'
+ '[' monitor-upgrade = datanode ']'
+ '[' finalize-upgrade = datanode ']'
+ '[' mkdir = datanode ']'
+ '[' nfs3 = datanode ']'
+ '[' namenode = datanode -o secondarynamenode = datanode -o datanode = datanode ']'
+ HADOOP_OPTS='-Dsecurity.audit.logger=INFO,RFAS -Djava.net.preferIPv4Stack=true '
+ export 'HADOOP_OPTS=-Dhdfs.audit.logger=INFO,RFAAUDIT -Dsecurity.audit.logger=INFO,RFAS -Djava.net.preferIPv4Stack=true '
+ HADOOP_OPTS='-Dhdfs.audit.logger=INFO,RFAAUDIT -Dsecurity.audit.logger=INFO,RFAS -Djava.net.preferIPv4Stack=true '
+ exec /opt/cloudera/parcels/CDH-5.0.0-1.cdh5.0.0.p0.47/lib/hadoop-hdfs/bin/hdfs --config /var/run/cloudera-scm-agent/process/317-hdfs-DATANODE datanode
log4j:ERROR Could not find value for key log4j.appender.EventCounter
log4j:ERROR Could not instantiate appender named "EventCounter".I check the parcels folders of HDFS to see if EvenCounter as well configurer and it does...
Do you know how to fix that ?
Edit: http://pastebin.com/jKwY1JXv
BR
NicolasY.
Created 05-06-2014 04:24 AM
Created 05-03-2014 08:22 AM
Created on 05-05-2014 05:40 AM - edited 05-05-2014 06:48 AM
Hi Hars,
Thanks for your support.
Please find the today's log from one of both DN concerned. (Log DN)
I can see an FATAL message about BindException : Cannot Assigned requested address.
Thanks again.
BR
NicolasY
Created 05-06-2014 04:24 AM
Created 05-06-2014 07:49 AM
Created 05-07-2017 12:04 PM
I have the same problem! Where did you change the name of the server? Can you please give more details?
Created 05-07-2017 12:10 PM
I am having the same problem! Where did you change the name of the server exactly? Can you please give more details?
Thanks in advance