Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 03-17-2018 06:13 PM - edited 09-16-2022 05:59 AM
Hi,
I am using Apache Knox to access Ambari but without much success. I defined a topology that looks correct to me, I added Ranger policies but it doesn't work. I can access other services such Yarn RM and WebHDFS without issues.
There's no errors in Knox logs. Any idea on how to debug this?
Thanks
Matthieu
Created 03-17-2018 06:33 PM
Hi
What error are you facing?
If it's HTTP authorization error, then check Ranger audit to understand what's happening. Make sure that you have the right Ranger policies for UI and API.
Created 03-17-2018 06:33 PM
Hi
What error are you facing?
If it's HTTP authorization error, then check Ranger audit to understand what's happening. Make sure that you have the right Ranger policies for UI and API.
Created 03-17-2018 08:47 PM
Thank you very much. The Ranger audit was helpful to understand what's happening. My API policy was not correct.