Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Issues with Knox and Ambari

avatar
New Member

Hi,

I am using Apache Knox to access Ambari but without much success. I defined a topology that looks correct to me, I added Ranger policies but it doesn't work. I can access other services such Yarn RM and WebHDFS without issues.

There's no errors in Knox logs. Any idea on how to debug this?

Thanks

Matthieu

1 ACCEPTED SOLUTION

avatar

Hi

What error are you facing?

If it's HTTP authorization error, then check Ranger audit to understand what's happening. Make sure that you have the right Ranger policies for UI and API.

View solution in original post

2 REPLIES 2

avatar

Hi

What error are you facing?

If it's HTTP authorization error, then check Ranger audit to understand what's happening. Make sure that you have the right Ranger policies for UI and API.

avatar
New Member

Thank you very much. The Ranger audit was helpful to understand what's happening. My API policy was not correct.