Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Master failed to complete initialization after 900000ms

avatar
Super Collaborator

HMaster: Master failed to complete initialization after 900000ms. Please consider submitting a bug report including a thread dump of this process

I guess it got something to do with Zookeeper.

HDP 2.3.4

1 ACCEPTED SOLUTION

avatar
Super Collaborator

this issue is fixed. root cause is /etc/hosts on worker nodes. we had to add /etc/hosts to test another component and i did not follow the order , FQDN is not followed by ip. that was the reason RS freaked-out.

View solution in original post

3 REPLIES 3

avatar
Super Guru

Want to add some logs? A thread dump as the message instructs you to do? 🙂

avatar
Super Collaborator

this issue is fixed. root cause is /etc/hosts on worker nodes. we had to add /etc/hosts to test another component and i did not follow the order , FQDN is not followed by ip. that was the reason RS freaked-out.

avatar

What changes you had to do in /etc/hosts file on RegionServer/Master?