Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

NiFi PutHiveStreaming Fails With No jaas_unix error

avatar
Expert Contributor

I'm using the current build of NiFi 1.3 with an HDP 2.6.1.0 Development Cluster without Kerberos and the Hive Streaming Processor is returning an error about no jaas_unix in java.library.path when it tries to connect to the Hive Thrift Server. I'm able to connect to Hive otherwise in NiFi with the PutHiveQL processor so I'm not sure what's going on.Here is the full error nifi-error.txt

1 ACCEPTED SOLUTION

avatar
Expert Contributor

It turns out this caused by updating OpenJDK while NiFi is running. I didn't notice one of the admins had run updates earlier and a restart of NiFi made the issue go away.

View solution in original post

1 REPLY 1

avatar
Expert Contributor

It turns out this caused by updating OpenJDK while NiFi is running. I didn't notice one of the admins had run updates earlier and a restart of NiFi made the issue go away.