Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Nifi Site-to-site: Source throws error "Unable to find port with id xyz" ; But in destination port with id xyz exist

avatar
New Member

I got problem while setting up nifi site to site.

Source throws error "Unable to find port with id xyz" ; But in destination port with id xyz exist.
Please find below link for screenshots.

Any help please.

Screenshots: https://drive.google.com/drive/folders/0B63F0W31MWMqRTY1UDFWMGFncTA?usp=sharing

1 ACCEPTED SOLUTION

avatar
New Member

The problem is due to improper configuration on nifi.properties
Please make sure: you have following properties in nifi-1.4.0/conf/nifi.properties:

# Site to Site properties

nifi.remote.input.host=192.168.2.8 # Previously it was localhost when I was getting error

nifi.remote.input.socket.port=10000 # Your destination machine should have allowed this port

View solution in original post

1 REPLY 1

avatar
New Member

The problem is due to improper configuration on nifi.properties
Please make sure: you have following properties in nifi-1.4.0/conf/nifi.properties:

# Site to Site properties

nifi.remote.input.host=192.168.2.8 # Previously it was localhost when I was getting error

nifi.remote.input.socket.port=10000 # Your destination machine should have allowed this port