Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-03-2017 08:39 PM
ERROR from falcon application log
=================
After installing falcon I see SERVICE UNAVAILABLE ERROR on falcon UI . On restart of falcon service see the below error which points hdfs:hdfs is user & group ownership and falcon cannot execute .
017-02-03 20:10:46,874 INFO ipc.Server (Server.java:logException(2394)) - IPC Server handler 105 on 8020, call org.apache.hadoop.hdfs.protocol.ClientProtocol.getFileInfo from 192. 168.1.95:43132 Call#0 Retry#0: org.apache.hadoop.security.AccessControlException: Permission denied: user=falcon, access=EXECUTE, inode="/apps/falcon/extensions":hdfs:hdfs:drwx-----
Below is the output of hadoop fs -ls ...
[root@hdpkdc ~]# hadoop fs -ls /apps/falcon Found 1 items drwxr-xr-x - falcon users 0 2017-02-02 20:53 /apps/falcon/extensions [root@hdpkdc ~]# hadoop fs -ls /apps/falcon/extensions Found 4 items drwxr-xr-x - falcon users 0 2017-02-02 20:53 /apps/falcon/extensions/hdfs-mirroring drwxr-xr-x - falcon users 0 2017-02-02 20:53 /apps/falcon/extensions/hdfs-snapshot-mirroring drwxr-xr-x - falcon users 0 2017-02-02 20:53 /apps/falcon/extensions/hive-mirroring drwxrwx--- - falcon users 0 2017-02-02 20:53 /apps/falcon/extensions/mirroring
Thanks,
Jagdish
Created 02-07-2017 01:06 PM
Ranger HDFS policy were configured was but since Hadoop ACL's are in place it should have let falcon user in .
As a workaround we tried a different path and that worked . Unable to replicate the same again . I guess we can close this ticket for now .
Thanks ...
Created 02-03-2017 09:30 PM
Are you using ranger for HDFS ACL? If yes configure ranger policy accordingly.
Created 02-07-2017 09:55 AM
@Jagdish Saripella Please check permissions/ownership for /apps/falcon. It should set as below.
[root@HOST]# hdfs dfs -ls -d /apps/falcon
drwxrwxrwx - falcon hdfs 0 2016-12-08 11:48 /apps/falcon
Also, check corresponding policies in ranger.
Created 02-07-2017 01:06 PM