Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-01-2016 05:25 PM
I have a table in HBase created via Phoenix. The table has approxmiately 20 million records. I'm connecting to Phoenix via:
phoenix-sqlline.py hbasemaster:2181:/hbase-unsecure
I'm trying to run a count as follows:
select count(columnname) from tablename;
When I run that SQL, Phoenix reports a timeout
org.apache.phoenix.exception.PhoenixIOException: org.apache.phoenix.exception.PhoenixIOException: Failed after attempts=36, exceptions: java.net.SocketTimeoutException: callTimeout=60000, callDuration=60317: row ....
I've tried changing the hbase.rpc.timeout via Ambari, but that doesn't seem to be the issue. The default timeout in Ambari was set to 1m30s and I changed it to 2m. The timeout reported by Phoenix is 60s before and after the change, so I don't think that's the culprit anyway.
What setting do I need to change to allow for longer running queries? Is there something else that I should be looking at?
Created 02-01-2016 05:53 PM
There is an odd environment variable used for the HBase configuration directory. Try setting HBASE_CONF_PATH=/etc/hbase/conf in your shell session and see if the timeout value gets picked up.
Created 02-01-2016 05:53 PM
There is an odd environment variable used for the HBase configuration directory. Try setting HBASE_CONF_PATH=/etc/hbase/conf in your shell session and see if the timeout value gets picked up.
Created 02-01-2016 07:42 PM
This was the issue. Well more specifically HBASE_CONF_DIR. Running phoenix_utils.py showed HBASE_CONF_PATH and HBASE_CONF_DIR as equal to ".". I set my HBASE_CONF_DIR environment variable to to use "/etc/hbase/conf" and now the query seems to work ok.
Created 06-16-2016 09:22 PM
FWIW, this should be fixed in recent versions of Apache Phoenix and HDP.
Created 05-20-2016 04:38 PM
Hi @Terry Padgett @Josh Elser,
I am using DBVisulizer to connect to Phoenix. Mine is a kerberos enabled cluster and getting below error messages. Can suggestions?
An error occurred while establishing the connection: Long Message: callTimeout=600000, callDuration=620131: Details: Type: org.apache.phoenix.exception.PhoenixIOException Error Code: 101 SQL State: 08000
Not sure how I can pass conf directory for DBVisulizer (added all conf files to Resoucres directory of DbViz but didn't helped)
Created 07-29-2016 10:39 AM
Hi All,
I set phoenix timeout is 3hr, rpc 3hr and query alive is also 3hr but for bigger query whenever phoenix calltimeout occurs my hbase region server also goes down, I don not know what is happening.
Please help me out on this. @Terry Padgett
Created 07-04-2017 09:53 AM
Below KB article helped me to resolve the issue.
Created 04-28-2021 05:00 PM
Frustrating that that link is hidden behind a 'paywall'. I have an account but I am not allowed to view without contacting sales