Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 10-24-2018 05:12 AM - edited 09-16-2022 06:49 AM
Dear Cloudera Community, please help me to solve the problem with Pig job.
Some users not all have problems with script
events = load '/data/events/default/year=2018/month=07' using AvroStorage();
ev = limit events 100;
dump
The error looks like
2018-10-24 16:06:12,483 [main] INFO org.apache.pig.backend.hadoop.executionengine.mapReduceLayer.MapReduceLauncher - Failed!
2018-10-24 16:06:12,485 [main] ERROR org.apache.pig.tools.grunt.Grunt - ERROR 1066: Unable to open iterator for alias ev
Details at logfile: /data/users/bigdata17/pig_1540382728474.log
All users are in the same group and have permissions to read on the folders.
HadoopVersion 5.9.3
Pig 0.12.0
Created 10-28-2018 11:30 PM
The problem was in SSSD
Created 10-24-2018 05:51 AM
Yarn log
Diagnostics: Application application_1540299431797_0022 initialization failed (exitCode=255) with output: main : command provided 0
main : run as user is ххх
main : requested yarn user is ххх
User ххх not found
Failing this attempt. Failing the application
Created 10-28-2018 11:30 PM
The problem was in SSSD