Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 05-23-2016 02:51 PM
Pig jobs work from gateway node but fail from ambari-view. I crosschecked configs with proxyusers and I have ambariid which is running ambari-server configured there.
Error from RM shows this.
AM Container for appattempt_1463770749228_0048_000001 exited with exitCode: -1000 For more detailed output, check application tracking page:http://<hostname>:8088/cluster/app/application_1463770749228_0048Then, click on links to logs of each attempt. Diagnostics: ExitCodeException exitCode=2: gzip: /grid/6/hadoop/yarn/local/filecache/33_tmp/tmp_pig.tar.gz: unexpected end of file tar: Unexpected EOF in archive tar: Unexpected EOF in archive tar: Error is not recoverable: exiting now Failing this attempt
Error from Pig view is File does not exist: /user/rmutyal/pig/jobs/test_23-05-2016-14-46-54/stdout but webhcat user configuration looks alright. What am I missing?
Created 05-25-2016 02:41 PM
This is a case of corrupt pig.tar.gz in hdfs (/hdp/apps/<version>/pig) folder. I am not sure how it ended up with a corrupt version there on a fresh install based on ambari. But once I manually updated with pig.tar.gz from /usr/hdp/<version>/pig/, the error got resolved.
However, confusing part is pig view throwing a completed unrelated error (File does not exist at /user/rmutyal/pig/jobs/test_23-05-2016-14-46-54/stdout)
Created 05-23-2016 03:28 PM
Please check HTTP Proxy. Change them as below in core-site.xml and restart affected services:
hadoop.proxyuser.HTTP.groups = * hadoop.proxyuser.HTTP.hosts = *
Let me know if you are able to execute. It worked for me.
Created 05-23-2016 04:12 PM
No luck with that. This is a cluster with https configured for ambari
Created 05-25-2016 02:41 PM
This is a case of corrupt pig.tar.gz in hdfs (/hdp/apps/<version>/pig) folder. I am not sure how it ended up with a corrupt version there on a fresh install based on ambari. But once I manually updated with pig.tar.gz from /usr/hdp/<version>/pig/, the error got resolved.
However, confusing part is pig view throwing a completed unrelated error (File does not exist at /user/rmutyal/pig/jobs/test_23-05-2016-14-46-54/stdout)