Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 07-10-2018 05:51 AM - edited 09-16-2022 06:26 AM
Hello Experts,
I am using presto (v 0.194) on AWS EMR (v 5.14.0) as querying layer.
Data is stored in Hadoop data nodes.
Issue : When querying Hive table with ACID property enabled, Presto query fails with below error ( attached document presto-query-errors.txt has full errors)
select * from default.poc_date_bucket limit 10
An error occurred while calling o163.next. : java.sql.SQLException: Query failed (#20180709_164933_00004_hgb6d): Hive table 'default.poc_date_bucket' is corrupt. Found sub-directory in bucket directory for partition: <UNPARTITIONED> at com.facebook.presto.jdbc.PrestoResultSet.resultsException(PrestoResultSet.java:1798) at
Creating a new table with partitioning and bucketing enabled, query fails with similar error
select * from default.poc_date_partition limit 10
An error occurred while calling o169.next. : java.sql.SQLException: Query failed (#20180709_174041_00005_hgb6d): Hive table 'default.poc_date_partition' is corrupt. Found sub-directory in bucket directory for partition: year_start_date=2019-01-01 at com.facebook.presto.jdbc.PrestoResultSet.resultsException(PrestoResultSet.java:1798) at
Bucketing is required when enabling ACID property on a Hive table.
Has anyone encountered this issue? Appreciate any suggestions
Thanks again
Created 07-11-2018 11:25 PM
Hey @cskbhatt! When you use hive transactional table it seems to be an unsupported feature by presto.
https://github.com/prestodb/presto/issues/1970
https://github.com/prestodb/presto/issues/6666
Hope this helps!
Created 07-11-2018 11:25 PM
Hey @cskbhatt! When you use hive transactional table it seems to be an unsupported feature by presto.
https://github.com/prestodb/presto/issues/1970
https://github.com/prestodb/presto/issues/6666
Hope this helps!
Created 07-12-2018 06:23 AM
Thank you @Vinicius Higa Murakami for sharing the issues.
I am exploring alternatives to presto, for querying star schemas (built on hive ACID tables)
Created 04-09-2020 08:26 AM
So Presto now supports ACID tables, but only for Hive3. However, the subdirectory exception is from a configuration on the presto client side. In the hive.properties in presto's catalog directory, add "hive.recursive-directories=true"