Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-14-2016 07:05 PM
I'm trying to use the HW Hive ODBC driver; I've installed the package, set up a stanza in my odbc.ini, and put
.hortonworks.hiveodbc.ini in my $HOME. When I try connecting, I get the message:
ERROR: 0: HY000 : [DataDirect][ODBC lib] Unicode converter buffer overflow
I've tried adding "DriverUnicodeType=1" (and 2) to odbc.ini, to no avail. What can I try next.
Created 03-15-2016 04:28 PM
Update: I had been using DataDirect as the ODBC Driver Manager. When I switched to unixODBC, the problem appears to have been resolved.
Created 03-14-2016 07:16 PM
See this http://www-01.ibm.com/support/docview.wss?uid=swg21580747
It may be a configuration setting at your end that needs to be changed in order to prevent the unicode converter buffer overflow
Created 03-14-2016 07:21 PM
Thanks! for your reply. Sounds reasonable, but which configuration and what setting?
Created 03-14-2016 07:25 PM
@Mark Lavin odbc.ini
The DataDirect ODBC driver manager looks for a property that you can add to the Data Source Name (DSN) entry for the 3rd party driver in the .odbc.ini file to indicate if the driver is using 2 or 4 bytes for unicode. Add the following property after the "driver=" line for the failing DSN in the .odbc.ini file: DriverUnicodeType=1 then test the failing scenario. If the error still occurs, then change the line to: DriverUnicodeType=2
Created 03-14-2016 07:41 PM
Yup, tried that, no luck.
Created 03-14-2016 07:50 PM
Created 03-14-2016 07:58 PM
Good questions. I placed .hortonworks.hiveodbc.ini in $HOME; for .odbc.ini, I actually have an odbc.ini in another directory but I set $ODCBINI to point to it; for .odbcinst.ini, I read that it was optional, so I omitted it.
Created 03-15-2016 02:09 AM
Did you install
[root@abc ~]# rpm -qa | grep hive-odbc-native
hive-odbc-native-2.0.0.1000-1.x86_64
[root@abc ~]#
Created 03-15-2016 01:16 PM
No, the rpm package was named
hive-odbc-native-2.0.5.1005-1.el6.x86_64.rpm
Created 03-15-2016 04:28 PM
Update: I had been using DataDirect as the ODBC Driver Manager. When I switched to unixODBC, the problem appears to have been resolved.