Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-15-2016 08:29 AM
When trying to upgrade ambari in the HDP 2.5. sandbox everthing works until step 9 of the documentation "Upgrade Ambari Server database schema" (http://docs.hortonworks.com/HDPDocuments/Ambari-2.4.2.0/bk_ambari-upgrade/content/upgrade_ambari.html).
When I execute ambari-server upgrade I get the following error:
[root@sandbox scripts]# ambari-server upgrade -v
Using python /usr/bin/python
Upgrading ambari-server
Updating properties in ambari.properties ...
WARNING: Can not find ambari.properties.rpmsave file from previous version, skipping import of settings
INFO: Can not find ambari-env.sh.rpmsave file from previous version, skipping restore of environment settings. ambari-env.sh may not include any user customization.
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: ===========================================================================================
INFO: Executing Mpack Replay Log :
INFO: {'purge': False, 'mpack_command': 'install-mpack', 'mpack_path': '/var/lib/ambari-server/resources/mpacks/cache/solr-service-mpack-5.5.2.2.5.tar.gz', 'force': False, 'verbose': False}
INFO: ===========================================================================================
INFO: Installing management pack /var/lib/ambari-server/resources/mpacks/cache/solr-service-mpack-5.5.2.2.5.tar.gz
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: Download management pack to temp location /var/lib/ambari-server/data/tmp/solr-service-mpack-5.5.2.2.5.tar.gz
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: Expand management pack at temp location /var/lib/ambari-server/data/tmp/solr-service
Traceback (most recent call last):
File "/usr/sbin/ambari-server.py", line 754, in <module>
mainBody()
File "/usr/sbin/ambari-server.py", line 725, in mainBody
main(options, args, parser)
File "/usr/sbin/ambari-server.py", line 678, in main
action_obj.execute()
File "/usr/sbin/ambari-server.py", line 69, in execute
self.fn(*self.args, **self.kwargs)
File "/usr/lib/python2.6/site-packages/ambari_server/serverUpgrade.py", line 358, in upgrade
replay_mpack_logs()
File "/usr/lib/python2.6/site-packages/ambari_server/setupMpacks.py", line 826, in replay_mpack_logs
install_mpack(replay_options, replay_mode=True)
File "/usr/lib/python2.6/site-packages/ambari_server/setupMpacks.py", line 764, in install_mpack
(mpack_metadata, mpack_name, mpack_version, mpack_staging_dir, mpack_archive_path) = _install_mpack(options, replay_mode)
File "/usr/lib/python2.6/site-packages/ambari_server/setupMpacks.py", line 620, in _install_mpack
tmp_root_dir = expand_mpack(tmp_archive_path)
File "/usr/lib/python2.6/site-packages/ambari_server/setupMpacks.py", line 148, in expand_mpack
sudo.rmtree(tmp_root_dir)
File "/usr/lib/python2.6/site-packages/resource_management/core/sudo.py", line 102, in rmtree
shutil.rmtree(path)
File "/usr/lib64/python2.6/shutil.py", line 212, in rmtree
rmtree(fullname, ignore_errors, onerror)
File "/usr/lib64/python2.6/shutil.py", line 212, in rmtree
rmtree(fullname, ignore_errors, onerror)
File "/usr/lib64/python2.6/shutil.py", line 212, in rmtree
rmtree(fullname, ignore_errors, onerror)
File "/usr/lib64/python2.6/shutil.py", line 212, in rmtree
rmtree(fullname, ignore_errors, onerror)
File "/usr/lib64/python2.6/shutil.py", line 212, in rmtree
rmtree(fullname, ignore_errors, onerror)
File "/usr/lib64/python2.6/shutil.py", line 221, in rmtree
onerror(os.rmdir, path, sys.exc_info())
File "/usr/lib64/python2.6/shutil.py", line 219, in rmtree
os.rmdir(path)
OSError: [Errno 22] Invalid argument: '/var/lib/ambari-server/data/tmp/solr-service/common-services/SOLR/5.5.2.2.5/package/scripts'
Created 12-28-2016 04:29 PM
Seems that the problem only manifests with the VMWare based version of the Sandbox. If I directly use the docker image on my Ubuntu Desktop, I'm able to do the upgrade of ambari without problems.
Created 12-17-2016 02:32 AM
the solr ambari mpack is failing. can you take at look at this post
https://community.hortonworks.com/questions/65919/solr-install-fails-on-hdp-25-sandbox.html
Created 12-28-2016 04:29 PM
Seems that the problem only manifests with the VMWare based version of the Sandbox. If I directly use the docker image on my Ubuntu Desktop, I'm able to do the upgrade of ambari without problems.