Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-06-2016 06:54 PM
Dear All, just trying to run the tutorial and everything works fine until I start the Kafka Producer.
My Setup: HDP-2.3.4.0-3485 on a 3N Yarn Setup
I am getting the following error in the k-event-processor-3-1454777987-worker-6700.log
2016-02-06 17:28:05.220 o.a.z.ZooKeeper [INFO] Client environment:java.io.tmpdir=/tmp 2016-02-06 17:28:05.220 o.a.z.ZooKeeper [INFO] Client environment:java.compiler=<NA> 2016-02-06 17:28:05.220 o.a.z.ZooKeeper [INFO] Client environment:os.name=Linux 2016-02-06 17:28:05.220 o.a.z.ZooKeeper [INFO] Client environment:os.arch=amd64 2016-02-06 17:28:05.220 o.a.z.ZooKeeper [INFO] Client environment:os.version=3.10.0-229.14.1.el7.x86_64 2016-02-06 17:28:05.220 o.a.z.ZooKeeper [INFO] Client environment:user.name=storm 2016-02-06 17:28:05.220 o.a.z.ZooKeeper [INFO] Client environment:user.home=/home/storm 2016-02-06 17:28:05.220 o.a.z.ZooKeeper [INFO] Client environment:user.dir=/home/storm 2016-02-06 17:28:05.221 o.a.z.ZooKeeper [INFO] Initiating client connection, connectString=.....:2181,....:2181,....:2181, sessionTimeout=20000 watcher=org.apache.curator.ConnectionState@209d0f1c 2016-02-06 17:28:05.283 o.a.c.f.i.CuratorFrameworkImpl [INFO] Starting 2016-02-06 17:28:05.286 o.a.z.ClientCnxn [INFO] Opening socket connection to server .....:2181. Will not attempt to authenticate using SASL (unknown error) 2016-02-06 17:28:05.286 o.a.z.ZooKeeper [INFO] Initiating client connection, connectString=localhost sessionTimeout=20000 watcher=org.apache.curator.ConnectionState@33745cd 2016-02-06 17:28:05.287 o.a.z.ClientCnxn [INFO] Socket connection established to .....:2181, initiating session 2016-02-06 17:28:05.318 o.a.z.ClientCnxn [INFO] Opening socket connection to server localhost/127.0.0.1:2181. Will not attempt to authenticate using SASL (unknown error) 2016-02-06 17:28:05.319 o.a.z.ClientCnxn [WARN] Session 0x0 for server null, unexpected error, closing socket connection and attempting reconnect java.net.ConnectException: Connection refused at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method) ~[?:1.8.0_60] at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:717) ~[?:1.8.0_60] at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:361) ~[zookeeper-3.4.6.2.3.4.0-3485.jar:3.4.6-3485--1] at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1125) [zookeeper-3.4.6.2.3.4.0-3485.jar:3.4.6-3485--1] 2016-02-06 17:28:05.340 o.a.z.ClientCnxn [INFO] Session establishment complete on server hdp1n1.aye1vpcdev/10.0.202.157:2181, sessionid = 0x152b6fb9a45005e, negotiated timeout = 20000 2016-02-06 17:28:05.345 o.a.c.f.s.ConnectionStateManager [INFO] State change: CONNECTED 2016-02-06 17:28:05.434 o.a.z.ClientCnxn [INFO] Opening socket connection to server localhost/0:0:0:0:0:0:0:1:2181. Will not attempt to authenticate using SASL (unknown error) 2016-02-06 17:28:05.435 o.a.z.ClientCnxn [WARN] Session 0x0 for server null, unexpected error, closing socket connection and attempting reconnect
Any Idea what I am doing wrong?
Created 02-07-2016 07:57 AM
Dear All, I found the solution to the problem ... zookeeper has to be installed on the nodes the supervisors are running on ... why that is? I don't know ... thanks for your support!
Created 02-06-2016 09:52 PM
storm.zookeeper.servers in the storm config is set to my three servers running zookeeper (as per Ambaris default) so unfortunately this isn't the solution 😞
Created 02-07-2016 07:57 AM
Dear All, I found the solution to the problem ... zookeeper has to be installed on the nodes the supervisors are running on ... why that is? I don't know ... thanks for your support!
Created 02-07-2016 11:46 AM
@Rainer Geissendoerfer Thats the easy fix and its because somewhere in the code , it may be looking for localhost:2181