Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 09-16-2016 02:29 PM
I am getting following error while installing ranger-admin from ambari
2016-09-16 14:15:24,498 [JISQL] /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.71-2.b15.el7_2.x86_64/bin/java -cp /usr/share/java/mysql-connector-java.jar :/usr/hdp/current/ranger-admin/jisql/lib/* org.apache.util.sql.Jisql -driver mysqlconj -cstring jdbc:mysql://<host>/ranger -u 'rangeradmin' -p '********' -noheader -trim -c \; -query "SELECT version();" SQLException : SQL state: 28000 java.sql.SQLException: Access denied for user 'rangeradmin'@'host' (using password: YES) ErrorCode: 1045 2016-09-16 14:15:24,811 [E] Can't establish connection!! Exiting..
I have already given all required permission to rangeradmin , root , mapped them with host % , localhost what is that i am missing ? Pls help
Created 09-30-2016 01:12 PM
I have resolved the issue ,
In MySQL metastore 'rangeruser'@'ambariservernode' needs grant permission rights for installation to be successfull this is not documented in hortonworks installation doc
GRANT ALL PRIVILEGES ON *.* TO 'rangeruser'@'ambariservernode' WITH GRANT OPTION;
Created 09-16-2016 02:34 PM
Can you follow this document https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.3.0/bk_Ranger_Install_Guide/content/configuring... Also if you can provide a screenshot or log file, it will be helpful.
Created 09-16-2016 02:53 PM
pfa logs rangeradmin-install-logs.txt
I am following below link as per my HDP version https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.4.0/bk_Ranger_Install_Guide/content/ch_overview...
My ambari server and Rangeradmin are on different nodes
Rangeradmin and its mysql metastore are on same node
I am able to run python dba_script successfully on rangeradmin nodes specifying host as localhost
i am also able to run following command successfully from ambari server node , suggesting there is no firewall issue
nc ambaridbhostname 3306
Created 09-16-2016 04:57 PM
Did you followed this https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.4.0/bk_Ranger_Install_Guide/content/configuring... and run those MySQL queries?
Created 09-16-2016 05:00 PM
Yes that is correct
Created 09-16-2016 10:42 PM
as logs says permission denied so you need yo go to the db that you configured in ranger and grant the provilleges to root user for ranger admin host with grant options and then try again it will work something like:
grant all on Databases to 'root'@'hostname' identified by 'password' with grant option;
Flush privileges;
Created 09-19-2016 01:38 PM
no this is not working
problem is that i am not able to remote connect my mysql instance
these are azure VMs
Created 09-26-2016 01:07 PM
any update please
Created 09-30-2016 01:12 PM
I have resolved the issue ,
In MySQL metastore 'rangeruser'@'ambariservernode' needs grant permission rights for installation to be successfull this is not documented in hortonworks installation doc
GRANT ALL PRIVILEGES ON *.* TO 'rangeruser'@'ambariservernode' WITH GRANT OPTION;
Created 09-08-2022 07:16 PM
Think u ,it works!🤗